Shopware 6 allows attackers to check for registered accounts through the store-api
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-204.
Summary
Shopware 6 is an open commerce platform based on Symfony Framework and Vue. Through the store-api it is possible as a attacker to check if a specific e-mail address has an account in the shop. Using the store-api endpoint /store-api/account/recovery-password you get the response, which indicates clearly that there is no account for this customer. In contrast you get a success response if the account was found. This vulnerability is fixed in Shopware 6.6.10.3 or 6.5.8.17. For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopware | shopware | before 6.5.8.17; 6.6.0.0 to before 6.6.10.3; 6.7.0.0-rc1 to before 6.7.0.0-rc2 | 6.5.8.17, 6.6.10.3, 6.7.0.0-rc2 | Patch available | CNA |
| — | shopware/core (Packagist) | 6.6.0.0 to before 6.6.10.3 | 6.6.10.3 | Patch available | GHSA-hh7j-6x3q-f52h |
| — | shopware/platform (Packagist) | 6.6.0.0 to before 6.6.10.3 | 6.6.10.3 | Patch available | GHSA-hh7j-6x3q-f52h |
| — | shopware/core (Packagist) | 6.7.0.0-rc1 to before 6.7.0.0-rc2 | 6.7.0.0-rc2 | Patch available | GHSA-hh7j-6x3q-f52h |
| — | shopware/platform (Packagist) | 6.7.0.0-rc1 to before 6.7.0.0-rc2 | 6.7.0.0-rc2 | Patch available | GHSA-hh7j-6x3q-f52h |
| — | shopware/core (Packagist) | before 6.5.8.18 | 6.5.8.18 | Patch available | GHSA-hh7j-6x3q-f52h |
| — | shopware/platform (Packagist) | before 6.5.8.18 | 6.5.8.18 | Patch available | GHSA-hh7j-6x3q-f52h |
- shopware Vendorshopware Affected before 6.5.8.17; 6.6.0.0 to before 6.6.10.3; 6.7.0.0-rc1 to before 6.7.0.0-rc2 Fixed in 6.5.8.17, 6.6.10.3, 6.7.0.0-rc2 Patch available CNA
- shopware/core (Packagist) Vendor— Affected 6.6.0.0 to before 6.6.10.3 Fixed in 6.6.10.3 Patch available GHSA-hh7j-6x3q-f52h
- shopware/platform (Packagist) Vendor— Affected 6.6.0.0 to before 6.6.10.3 Fixed in 6.6.10.3 Patch available GHSA-hh7j-6x3q-f52h
- shopware/core (Packagist) Vendor— Affected 6.7.0.0-rc1 to before 6.7.0.0-rc2 Fixed in 6.7.0.0-rc2 Patch available GHSA-hh7j-6x3q-f52h
- shopware/platform (Packagist) Vendor— Affected 6.7.0.0-rc1 to before 6.7.0.0-rc2 Fixed in 6.7.0.0-rc2 Patch available GHSA-hh7j-6x3q-f52h
- shopware/core (Packagist) Vendor— Affected before 6.5.8.18 Fixed in 6.5.8.18 Patch available GHSA-hh7j-6x3q-f52h
- shopware/platform (Packagist) Vendor— Affected before 6.5.8.18 Fixed in 6.5.8.18 Patch available GHSA-hh7j-6x3q-f52h
Remediation
- Fix · CNA shopware (shopware) Fixed in 6.5.8.17, 6.6.10.3, 6.7.0.0-rc2
- Fix · GHSA-hh7j-6x3q-f52h shopware/core (Packagist) Fixed in 6.6.10.3 Advisory →
- Fix · GHSA-hh7j-6x3q-f52h shopware/platform (Packagist) Fixed in 6.6.10.3 Advisory →
- Fix · GHSA-hh7j-6x3q-f52h shopware/core (Packagist) Fixed in 6.7.0.0-rc2 Advisory →
- Fix · GHSA-hh7j-6x3q-f52h shopware/platform (Packagist) Fixed in 6.7.0.0-rc2 Advisory →
- Fix · GHSA-hh7j-6x3q-f52h shopware/core (Packagist) Fixed in 6.5.8.18 Advisory →
- Fix · GHSA-hh7j-6x3q-f52h shopware/platform (Packagist) Fixed in 6.5.8.18 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30150
- 2026-10-03 Alias added: GHSA-hh7j-6x3q-f52h
References
More Shopware vulnerabilities
- TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
- TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
- TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
- TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
- TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
- TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2025-30150 · CVE Program
- CVE-2025-30150 · NVD
- FIRST EPSS
- GHSA-hh7j-6x3q-f52h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences