Read the docs
TI-2025-21490 Aliases CVE-2025-30151GHSA-cgfj-hj93-rmh2

Shopware allows Denial Of Service via password length

Priority LOW 39CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Shopware is an open commerce platform. It's possible to pass long passwords that leads to Denial Of Service via forms in Storefront forms or Store-API. This vulnerability is fixed in 6.6.10.3 or 6.5.8.17. For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00425 37th percentileScored 2026-11-07
Fix Fixed shopware (shopware): 6.5.8.17, 6.6.10.3, 6.7.0.0-rc2shopware/core (Packagist): 6.6.10.3, 6.7.0.0-rc2, 6.5.8.17+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareshopwarebefore 6.5.8.17; 6.6.0.0 to before 6.6.10.3; 6.7.0.0-rc1 to before 6.7.0.0-rc26.5.8.17, 6.6.10.3, 6.7.0.0-rc2Patch availableCNA
—shopware/core (Packagist)6.6.0.0 to before 6.6.10.36.6.10.3Patch availableGHSA-cgfj-hj93-rmh2
—shopware/platform (Packagist)6.6.0.0 to before 6.6.10.36.6.10.3Patch availableGHSA-cgfj-hj93-rmh2
—shopware/core (Packagist)6.7.0.0-rc1 to before 6.7.0.0-rc26.7.0.0-rc2Patch availableGHSA-cgfj-hj93-rmh2
—shopware/platform (Packagist)6.7.0.0-rc1 to before 6.7.0.0-rc26.7.0.0-rc2Patch availableGHSA-cgfj-hj93-rmh2
—shopware/core (Packagist)before 6.5.8.176.5.8.17Patch availableGHSA-cgfj-hj93-rmh2
—shopware/platform (Packagist)before 6.5.8.176.5.8.17Patch availableGHSA-cgfj-hj93-rmh2
  • shopware Vendorshopware Affected before 6.5.8.17; 6.6.0.0 to before 6.6.10.3; 6.7.0.0-rc1 to before 6.7.0.0-rc2 Fixed in 6.5.8.17, 6.6.10.3, 6.7.0.0-rc2 Patch available CNA
  • shopware/core (Packagist) Vendor— Affected 6.6.0.0 to before 6.6.10.3 Fixed in 6.6.10.3 Patch available GHSA-cgfj-hj93-rmh2
  • shopware/platform (Packagist) Vendor— Affected 6.6.0.0 to before 6.6.10.3 Fixed in 6.6.10.3 Patch available GHSA-cgfj-hj93-rmh2
  • shopware/core (Packagist) Vendor— Affected 6.7.0.0-rc1 to before 6.7.0.0-rc2 Fixed in 6.7.0.0-rc2 Patch available GHSA-cgfj-hj93-rmh2
  • shopware/platform (Packagist) Vendor— Affected 6.7.0.0-rc1 to before 6.7.0.0-rc2 Fixed in 6.7.0.0-rc2 Patch available GHSA-cgfj-hj93-rmh2
  • shopware/core (Packagist) Vendor— Affected before 6.5.8.17 Fixed in 6.5.8.17 Patch available GHSA-cgfj-hj93-rmh2
  • shopware/platform (Packagist) Vendor— Affected before 6.5.8.17 Fixed in 6.5.8.17 Patch available GHSA-cgfj-hj93-rmh2

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.5.8.17; 6.6.0.0 to before 6.6.10.3Vulnerableshopware
cpe:2.3:a:shopware:shopware:6.7.0.0:rc1:*:*:*:*:*:*6.7.0.0 rc1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.5.8.17; 6.6.0.0 to before 6.6.10.3 Vulnerable ·shopware
  • cpe:2.3:a:shopware:shopware:6.7.0.0:rc1:*:*:*:*:*:* Versions 6.7.0.0 rc1 Vulnerable ·shopware

Remediation

  • Fix · CNA shopware (shopware) Fixed in 6.5.8.17, 6.6.10.3, 6.7.0.0-rc2
  • Fix · GHSA-cgfj-hj93-rmh2 shopware/core (Packagist) Fixed in 6.6.10.3 Advisory →
  • Fix · GHSA-cgfj-hj93-rmh2 shopware/platform (Packagist) Fixed in 6.6.10.3 Advisory →
  • Fix · GHSA-cgfj-hj93-rmh2 shopware/core (Packagist) Fixed in 6.7.0.0-rc2 Advisory →
  • Fix · GHSA-cgfj-hj93-rmh2 shopware/platform (Packagist) Fixed in 6.7.0.0-rc2 Advisory →
  • Fix · GHSA-cgfj-hj93-rmh2 shopware/core (Packagist) Fixed in 6.5.8.17 Advisory →
  • Fix · GHSA-cgfj-hj93-rmh2 shopware/platform (Packagist) Fixed in 6.5.8.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-30151
  2. 2026-10-03 Alias added: GHSA-cgfj-hj93-rmh2

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources