WordPress The Post Grid plugin <= 7.7.17 - Local File Inclusion vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-98.
Summary
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in RadiusTheme The Post Grid the-post-grid allows PHP Local File Inclusion.This issue affects The Post Grid: from n/a through <= 7.7.17.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| RadiusTheme | The Post Grid | up to 7.7.17 | — | No fix listed | CNA |
- The Post Grid VendorRadiusTheme Affected up to 7.7.17 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:radiustheme:the_post_grid:*:*:*:*:*:*:*:* | — | — | RadiusTheme |
- cpe:2.3:a:radiustheme:the_post_grid:*:*:*:*:*:*:*:* Versions — — ·RadiusTheme
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30814
- 2026-10-03 Alias added: GHSA-h535-j96r-875v
More RadiusTheme vulnerabilities
- TI-2022-02454 Classima < 2.1.11 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-26399 WordPress Plugin Testimonial Slider and Showcase 2.2.6 Stored XSS CVSS 4.0MEDIUM 5.1
- TI-2024-08572 Team Members Showcase < 4.4.2 - Editor+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-03390 The Post Grid < 7.5.0 - Editor+ Stored XSS via Grid Creation CVSS 3.1MEDIUM 4.8
- TI-2024-01623 Testimonial Slider < 2.3.7 - Author+ Settings Update CVSS 3.1MEDIUM 4.3
- TI-2026-67962 SQL injection in RadiusTheme Radius Booking WordPress plugin CVSS 3.1CRITICAL 9.3
Sources
- CVE-2025-30814 · CVE Program
- CVE-2025-30814 · NVD
- FIRST EPSS
- GHSA-h535-j96r-875v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences