WordPress Directorist AddonsKit for Elementor plugin <= 1.1.6 - Cross Site Scripting (XSS) vulnerability
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpWax Directorist AddonsKit for Elementor addonskit-for-elementor allows Stored XSS.This issue affects Directorist AddonsKit for Elementor: from n/a through <= 1.1.6.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0028 20th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-31857
- 2026-10-03 Alias added: GHSA-rpxq-378c-2wpg
More wpWax vulnerabilities
- TI-2022-03630 Directorist < 7.4.4 - Subscriber+ Sensitive Information Disclosure CVSS 3.1MEDIUM 6.5
- TI-2022-03605 Directorist < 7.4.2.2 - Subscriber+ Arbitrary User Password Update via IDOR CVSS 3.1MEDIUM 6.5
- TI-2026-42481 WordPress Directorist plugin <= 8.8.2 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-23723 WordPress HelpGent plugin <= 2.2.5 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-01866 Deserialization of untrusted data in wpWax Post Grid, Slider & Carousel Ultimate – with… CVSS 3.1HIGH 8.8
- TI-2026-02713 FormGent <= 1.9.2- Missing Authorization to Unauthenticated Arbitrary File Deletion via 'file_token' Parameter CVSS 3.1CRITICAL 9.1
Sources
- CVE-2025-31857 · CVE Program
- CVE-2025-31857 · NVD
- FIRST EPSS
- GHSA-rpxq-378c-2wpg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences