Moodle: unauthenticated rest api user data exposure
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
A flaw has been identified in Moodle where, on certain sites, unauthenticated users could retrieve sensitive user data—including names, contact information, and hashed passwords—via stack traces returned by specific API calls. Sites with PHP configured with zend.exception_ignore_args = 1 in the php.ini file are not affected by this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.5.0 – 4.5.2 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 4.5.0-beta to before 4.5.3 | 4.5.3 | Patch available | GHSA-345q-9jmq-g9q4 |
- moodle Vendor— Affected 4.5.0 – 4.5.2 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.3 Fixed in 4.5.3 Patch available GHSA-345q-9jmq-g9q4
Remediation
- Fix · GHSA-345q-9jmq-g9q4 moodle/moodle (Packagist) Fixed in 4.5.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-32044
- 2026-10-03 Alias added: GHSA-345q-9jmq-g9q4
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-32044 · CVE Program
- CVE-2025-32044 · NVD
- FIRST EPSS
- GHSA-345q-9jmq-g9q4 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-32044 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences