Moodle: hidden grades shown to users without permission on some grade reports
Priority LOW 30CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
A flaw has been identified in Moodle where insufficient capability checks in certain grade reports allowed users without the necessary permissions to access hidden grades.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00319 25th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 4.1.17, 4.3.11, 4.4.7 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.5.3; 4.4.7; 4.3.11; 4.1.17 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | before 4.1.17 | 4.1.17 | Patch available | GHSA-8m7c-hm88-2p97 |
| — | moodle/moodle (Packagist) | 4.3.0-beta to before 4.3.11 | 4.3.11 | Patch available | GHSA-8m7c-hm88-2p97 |
| — | moodle/moodle (Packagist) | 4.4.0-beta to before 4.4.7 | 4.4.7 | Patch available | GHSA-8m7c-hm88-2p97 |
| — | moodle/moodle (Packagist) | 4.5.0-beta to before 4.5.3 | 4.5.3 | Patch available | GHSA-8m7c-hm88-2p97 |
- moodle Vendor— Affected 4.5.3; 4.4.7; 4.3.11; 4.1.17 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.1.17 Fixed in 4.1.17 Patch available GHSA-8m7c-hm88-2p97
- moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.11 Fixed in 4.3.11 Patch available GHSA-8m7c-hm88-2p97
- moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.7 Fixed in 4.4.7 Patch available GHSA-8m7c-hm88-2p97
- moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.3 Fixed in 4.5.3 Patch available GHSA-8m7c-hm88-2p97
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 4.1.17; 4.3.0 to before 4.3.11; 4.4.0 to before 4.4.7; 4.5.0 to before 4.5.3 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.17; 4.3.0 to before 4.3.11; 4.4.0 to before 4.4.7; 4.5.0 to before 4.5.3 Vulnerable ·Moodle
Remediation
- Fix · GHSA-8m7c-hm88-2p97 moodle/moodle (Packagist) Fixed in 4.1.17 Advisory →
- Fix · GHSA-8m7c-hm88-2p97 moodle/moodle (Packagist) Fixed in 4.3.11 Advisory →
- Fix · GHSA-8m7c-hm88-2p97 moodle/moodle (Packagist) Fixed in 4.4.7 Advisory →
- Fix · GHSA-8m7c-hm88-2p97 moodle/moodle (Packagist) Fixed in 4.5.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-32045
- 2026-10-03 Alias added: GHSA-8m7c-hm88-2p97
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-32045 · CVE Program
- CVE-2025-32045 · NVD
- FIRST EPSS
- GHSA-8m7c-hm88-2p97 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-32045 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences