In Zammad 6.4.x before 6.4.2, there is client-side enforcement of server-side security.
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In Zammad 6.4.x before 6.4.2, there is client-side enforcement of server-side security. When changing their two factor authentication configuration, users need to re-authenticate with their current password first. However, this change was enforced in Zammad only on the front end level, and not when using the API directly.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Zammad GmbH | Zammad | 6.4 to before 6.4.2 | 6.4.2 | Patch available | CNA |
- Zammad VendorZammad GmbH Affected 6.4 to before 6.4.2 Fixed in 6.4.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zammad:zammad:*:*:*:*:*:*:*:* | 6.4.0 to before 6.4.2 | Vulnerable | Zammad GmbH |
- cpe:2.3:a:zammad:zammad:*:*:*:*:*:*:*:* Versions 6.4.0 to before 6.4.2 Vulnerable ·Zammad GmbH
Remediation
- Fix · CNA Zammad (Zammad) Fixed in 6.4.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Zammad 6.4.2
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2025-23442 In Zammad 6.4.x before 6.4.2, there is information exposure.Priority LOW 35
- TI-2025-23439 Authentication bypass in ZammadPriority LOW 20
- TI-2025-23440 Server-side request forgery in ZammadPriority LOW 19
Timeline
- 2026-10-02 Threatist record created from CVE-2025-32359
- 2026-10-03 Alias added: GHSA-g3qr-3fvc-4fm6
References
More Zammad GmbH Zammad vulnerabilities
- TI-2026-65406 Local privilege escalation in Zammad v1.5.0 to v7.2.2 installed via DEB or RPM package KEVCVSS 4.0CRITICAL 9.4
- TI-2026-65405 Undisclosed RCE in Zammad v6.3 and higher KEVCVSS 4.0CRITICAL 9.4
- TI-2024-22252 An issue was discovered in Zammad before 6.3.0. CVSS 3.1CRITICAL 9.1
- TI-2022-23785 A vulnerability in Zammad v5.3.0 allows attackers to execute arbitrary code or escalate… CVSS 3.1CRITICAL 9.8
- TI-2021-18599 An issue was discovered in Zammad before 4.1.1. CVSS 3.1CRITICAL 9.8
- TI-2021-18603 An issue was discovered in Zammad before 4.1.1. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-32359 · CVE Program
- CVE-2025-32359 · NVD
- FIRST EPSS
- GHSA-g3qr-3fvc-4fm6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences