Read the docs
TI-2025-23457 Aliases CVE-2025-32378GHSA-4h9w-7vfp-px8m

Shopware's default newsletter opt-in settings allow for mass sign-up abuse

Priority LOW 30CWE-799Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.

Summary

Shopware is an open source e-commerce software platform. Prior to 6.6.10.3 or 6.5.8.17, the default settings for double-opt-in allow for mass unsolicited newsletter sign-ups without confirmation. Default settings are Newsletter: Double Opt-in set to active, Newsletter: Double opt-in for registered customers set to disabled, and Log-in & sign-up: Double opt-in on sign-up set to disabled. With these settings, anyone can register an account on the shop using any e-mail-address and then check the check-box in the account page to sign up for the newsletter. The recipient will receive two mails confirming registering and signing up for the newsletter, no confirmation link needed to be clicked for either. In the backend the recipient is set to “instantly active”. This vulnerability is fixed in 6.6.10.3 or 6.5.8.17.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00317 24th percentileScored 2026-11-07
Fix Fixed shopware (shopware): 6.5.8.17, 6.6.10.3, 6.7.0.0-rc2shopware/core (Packagist): 6.6.10.3, 6.7.0.0-rc2, 6.5.8.17+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareshopwarebefore 6.5.8.17; 6.6.0.0 to before 6.6.10.3; 6.7.0.0-rc1 to before 6.7.0.0-rc26.5.8.17, 6.6.10.3, 6.7.0.0-rc2Patch availableCNA
—shopware/core (Packagist)6.6.0.0-rc1 to before 6.6.10.36.6.10.3Patch availableGHSA-4h9w-7vfp-px8m
—shopware/platform (Packagist)6.6.0.0-rc1 to before 6.6.10.36.6.10.3Patch availableGHSA-4h9w-7vfp-px8m
—shopware/platform (Packagist)6.7.0.0-rc1 to before 6.7.0.0-rc26.7.0.0-rc2Patch availableGHSA-4h9w-7vfp-px8m
—shopware/core (Packagist)6.7.0.0-rc1 to before 6.7.0.0-rc26.7.0.0-rc2Patch availableGHSA-4h9w-7vfp-px8m
—shopware/core (Packagist)before 6.5.8.176.5.8.17Patch availableGHSA-4h9w-7vfp-px8m
—shopware/platform (Packagist)before 6.5.8.176.5.8.17Patch availableGHSA-4h9w-7vfp-px8m
  • shopware Vendorshopware Affected before 6.5.8.17; 6.6.0.0 to before 6.6.10.3; 6.7.0.0-rc1 to before 6.7.0.0-rc2 Fixed in 6.5.8.17, 6.6.10.3, 6.7.0.0-rc2 Patch available CNA
  • shopware/core (Packagist) Vendor— Affected 6.6.0.0-rc1 to before 6.6.10.3 Fixed in 6.6.10.3 Patch available GHSA-4h9w-7vfp-px8m
  • shopware/platform (Packagist) Vendor— Affected 6.6.0.0-rc1 to before 6.6.10.3 Fixed in 6.6.10.3 Patch available GHSA-4h9w-7vfp-px8m
  • shopware/platform (Packagist) Vendor— Affected 6.7.0.0-rc1 to before 6.7.0.0-rc2 Fixed in 6.7.0.0-rc2 Patch available GHSA-4h9w-7vfp-px8m
  • shopware/core (Packagist) Vendor— Affected 6.7.0.0-rc1 to before 6.7.0.0-rc2 Fixed in 6.7.0.0-rc2 Patch available GHSA-4h9w-7vfp-px8m
  • shopware/core (Packagist) Vendor— Affected before 6.5.8.17 Fixed in 6.5.8.17 Patch available GHSA-4h9w-7vfp-px8m
  • shopware/platform (Packagist) Vendor— Affected before 6.5.8.17 Fixed in 6.5.8.17 Patch available GHSA-4h9w-7vfp-px8m

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.5.8.17; 6.6.0.0 to before 6.6.10.3Vulnerableshopware
cpe:2.3:a:shopware:shopware:6.7.0.0:rc1:*:*:*:*:*:*6.7.0.0 rc1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.5.8.17; 6.6.0.0 to before 6.6.10.3 Vulnerable ·shopware
  • cpe:2.3:a:shopware:shopware:6.7.0.0:rc1:*:*:*:*:*:* Versions 6.7.0.0 rc1 Vulnerable ·shopware

Remediation

  • Fix · CNA shopware (shopware) Fixed in 6.5.8.17, 6.6.10.3, 6.7.0.0-rc2
  • Fix · GHSA-4h9w-7vfp-px8m shopware/core (Packagist) Fixed in 6.6.10.3 Advisory →
  • Fix · GHSA-4h9w-7vfp-px8m shopware/platform (Packagist) Fixed in 6.6.10.3 Advisory →
  • Fix · GHSA-4h9w-7vfp-px8m shopware/platform (Packagist) Fixed in 6.7.0.0-rc2 Advisory →
  • Fix · GHSA-4h9w-7vfp-px8m shopware/core (Packagist) Fixed in 6.7.0.0-rc2 Advisory →
  • Fix · GHSA-4h9w-7vfp-px8m shopware/core (Packagist) Fixed in 6.5.8.17 Advisory →
  • Fix · GHSA-4h9w-7vfp-px8m shopware/platform (Packagist) Fixed in 6.5.8.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-32378
  2. 2026-10-03 Alias added: GHSA-4h9w-7vfp-px8m

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources