Read the docs
TI-2025-23514 Aliases CVE-2025-32444GHSA-hj4w-hm2g-p6w5

vLLM Vulnerable to Remote Code Execution via Mooncake Integration

Priority MEDIUM 52CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0182 78th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vllm (vllm-project): 0.8.5vllm (PyPI): 0.8.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vllm-projectvllm0.6.5 to before 0.8.50.8.5Patch availableCNA
—vllm (PyPI)0.6.5 to before 0.8.50.8.5Patch availableGHSA-hj4w-hm2g-p6w5
  • vllm Vendorvllm-project Affected 0.6.5 to before 0.8.5 Fixed in 0.8.5 Patch available CNA
  • vllm (PyPI) Vendor— Affected 0.6.5 to before 0.8.5 Fixed in 0.8.5 Patch available GHSA-hj4w-hm2g-p6w5

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*0.6.5 to before 0.8.5VulnerablevLLM
  • cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:* Versions 0.6.5 to before 0.8.5 Vulnerable ·vLLM

Remediation

  • Fix · CNA vllm (vllm-project) Fixed in 0.8.5
  • Fix · GHSA-hj4w-hm2g-p6w5 vllm (PyPI) Fixed in 0.8.5 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Critical. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat Enterprise Linux AI (RHEL AI)

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-32444
  2. 2026-10-03 Alias added: GHSA-hj4w-hm2g-p6w5

References

  • TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
  • TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
  • TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
  • TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
  • TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
  • TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
See all 124 →

Sources