A remote code execution vulnerability exists in HPE Insight Remote Support (IRS) prior to v7.15.0.646.
Priority MEDIUM 50CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-94.
Summary
A remote code execution vulnerability exists in HPE Insight Remote Support (IRS) prior to v7.15.0.646.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00761 55th percentileScored 2026-11-07
Fix Fixed Insight Remote Support (Hewlett Packard Enterprise): v7.15.0.646
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Hewlett Packard Enterprise | Insight Remote Support | before v7.15.0.646 | v7.15.0.646 | Patch available | CNA |
- Insight Remote Support VendorHewlett Packard Enterprise Affected before v7.15.0.646 Fixed in v7.15.0.646 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hpe:insight_remote_support:*:*:*:*:*:*:*:* | before 7.15.0.646 | Vulnerable | Hewlett Packard Enterprise (HPE) |
- cpe:2.3:a:hpe:insight_remote_support:*:*:*:*:*:*:*:* Versions before 7.15.0.646 Vulnerable ·Hewlett Packard Enterprise (HPE)
Remediation
- Fix · CNA Insight Remote Support (Hewlett Packard Enterprise) Fixed in v7.15.0.646
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Hewlett Packard Enterprise Insight Remote Support v7.15.0.646
3 records Highest priority Priority HIGH 2 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2025-25009 A vulnerability in HPE Insight Remote Support (IRS) prior to v7.15.0.646 may allow an unauthenticated denial of servicePriority HIGH 72
- TI-2025-25010 A path traversal vulnerability exists in HPE Insight Remote Support (IRS) prior to v7.15.0.646.Priority HIGH 69
Timeline
- 2026-10-02 Threatist record created from CVE-2025-37099
- 2026-10-03 Alias added: GHSA-grj5-8fx9-rjq9
References
More Hewlett Packard Enterprise vulnerabilities
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2015-02747 Heap-based buffer overflow in Adobe Flash Player before 13.0.0.296 and 14.x through 18.x… KEVCVSS 3.1CRITICAL 9.8
- TI-2013-04219 HP ProCurve Manager (PCM) 3.20 and 4.0, PCM+ 3.20 and 4.0, Identity Driven Manager (IDM)… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2005-02634 HP OpenView Network Node Manager 6.2 through 7.50 allows remote attackers to execute… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-07113 Integer overflow in Adobe Flash Player before 18.0.0.324 and 19.x and 20.x before… KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2025-37099 · CVE Program
- CVE-2025-37099 · NVD
- FIRST EPSS
- GHSA-grj5-8fx9-rjq9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences