Read the docs
TI-2025-26229 Aliases CVE-2025-39487GHSA-87rw-c4jp-4gjv

WordPress Rankie plugin <= 1.8.2 - Reflected Cross Site Scripting (XSS) vulnerability

Priority LOW 31CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ValvePress Rankie valvepress-rankie allows Reflected XSS.This issue affects Rankie: from n/a through <= 1.8.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0026 17th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ValvePressRankieup to 1.8.2—No fix listedCNA
  • Rankie VendorValvePress Affected up to 1.8.2 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-39487
  2. 2026-10-03 Alias added: GHSA-87rw-c4jp-4gjv

References

  • TI-2024-18559 WordPress Automatic plugin <= 3.92.0 - Unauthenticated Arbitrary SQL Execution vulnerability CVSS 3.1CRITICAL 9.9
  • TI-2021-03231 WordPress Automatic Plugin <= 3.53.2 - Unauthenticated Arbitrary Options Update CVSS 3.1CRITICAL 9.8
  • TI-2021-03237 Pinterest Automatic <= 4.14.3 - Unuathenticated Arbitrary Options Update CVSS 3.1CRITICAL 9.8
  • TI-2025-26252 WordPress Pinterest Automatic Pin plugin < 4.19.0 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
  • TI-2025-04847 Unrestricted file upload in ValvePress WordPress Automatic Plugin CVSS 3.1HIGH 8.8
  • TI-2025-26235 WordPress Rankie plugin < 1.8.2 - Broken Access Control Vulnerability CVSS 3.1HIGH 8.8
See all 14 →

Sources