Read the docs
TI-2025-29069 Aliases CVE-2025-46328GHSA-wmjq-jrm2-9wfr

NodeJS Driver for Snowflake has race condition when checking access to Easy Logging configuration file

Priority LOW 30CWE-367Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

snowflake-connector-nodejs is a NodeJS driver for Snowflake. Versions starting from 1.10.0 to before 2.0.4, are vulnerable to a Time-of-Check to Time-of-Use (TOCTOU) race condition. When using the Easy Logging feature on Linux and macOS the Driver reads logging configuration from a user-provided file. On Linux and macOS the Driver verifies that the configuration file can be written to only by its owner. That check was vulnerable to a TOCTOU race condition and failed to verify that the file owner matches the user running the Driver. This could allow a local attacker with write access to the configuration file or the directory containing it to overwrite the configuration and gain control over logging level and output location. This issue has been patched in version 2.0.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00172 6th percentileScored 2026-11-07
Fix Fixed snowflake-connector-nodejs (snowflakedb): 2.0.4snowflake-sdk (npm): 2.0.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Snowflakesnowflake-connector-nodejs1.10.0 to before 2.0.42.0.4Patch availableCNA
—snowflake-sdk (npm)1.10.0 to before 2.0.42.0.4Patch availableGHSA-wmjq-jrm2-9wfr
  • snowflake-connector-nodejs VendorSnowflake Affected 1.10.0 to before 2.0.4 Fixed in 2.0.4 Patch available CNA
  • snowflake-sdk (npm) Vendor— Affected 1.10.0 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-wmjq-jrm2-9wfr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:snowflake:snowflake_connector:*:*:*:*:*:node.js:*:*1.10.0 to before 2.0.4VulnerableSnowflake
  • cpe:2.3:a:snowflake:snowflake_connector:*:*:*:*:*:node.js:*:* Versions 1.10.0 to before 2.0.4 Vulnerable ·Snowflake

Remediation

  • Fix · CNA snowflake-connector-nodejs (snowflakedb) Fixed in 2.0.4
  • Fix · GHSA-wmjq-jrm2-9wfr snowflake-sdk (npm) Fixed in 2.0.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-46328
  2. 2026-10-03 Alias added: GHSA-wmjq-jrm2-9wfr

References

  • TI-2022-20945 Exponential ReDoS in snowflake-connector-python leads to denial of service CVSS 3.1HIGH 7.5
  • TI-2023-17069 Snowflake Python Connector vulnerable to Command Injection CVSS 3.1HIGH 8.8
  • TI-2023-17068 Snowflake NodeJS Driver vulnerable to Command Injection CVSS 3.1HIGH 8.8
  • TI-2023-17066 Snowflake Connector vulnerable to Command Injection CVSS 3.1HIGH 8.8
  • TI-2025-18511 The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache CVSS 3.1HIGH 7.8
  • TI-2025-18510 Snowflake Connector for Python has an SQL Injection in write_pandas CVSS 3.1HIGH 7.0
See all 12 →

Sources