YesWiki Remote Code Execution via Arbitrary PHP File Write and Execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki vulnerable to remote code execution. An arbitrary file write can be used to write a file with a PHP extension, which then can be browsed to in order to execute arbitrary code on the server, resulting in a full compromise of the server. This could potentially be performed unwittingly by a user. This issue has been patched in version 4.5.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| YesWiki | yeswiki | before 4.5.4 | 4.5.4 | Patch available | CNA |
| — | yeswiki/yeswiki (Packagist) | before 4.5.4 | 4.5.4 | Patch available | GHSA-88xg-v53p-fpvf |
- yeswiki VendorYesWiki Affected before 4.5.4 Fixed in 4.5.4 Patch available CNA
- yeswiki/yeswiki (Packagist) Vendor— Affected before 4.5.4 Fixed in 4.5.4 Patch available GHSA-88xg-v53p-fpvf
Remediation
- Fix · CNA yeswiki (YesWiki) Fixed in 4.5.4
- Fix · GHSA-88xg-v53p-fpvf yeswiki/yeswiki (Packagist) Fixed in 4.5.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-46347
- 2026-10-03 Alias added: GHSA-88xg-v53p-fpvf
References
More Yeswiki vulnerabilities
- TI-2025-29089 YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download CVSS 3.1CRITICAL 10.0
- TI-2024-34399 Use of a Broken or Risky Cryptographic Algorithm in YesWiki CVSS 3.1CRITICAL 9.9
- TI-2025-22392 Path Traversal allowing arbitrary read of files in Yeswiki CVSS 3.1HIGH 8.6
- TI-2025-17784 YesWiki Vulnerable to Unauthenticated DOM Based XSS CVSS 3.1HIGH 7.6
- TI-2025-29087 YesWiki Vulnerable to Stored XSS in Comments CVSS 4.0MEDIUM 6.3
- TI-2025-29090 YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting CVSS 3.1HIGH 7.6
Sources
- CVE-2025-46347 · CVE Program
- CVE-2025-46347 · NVD
- FIRST EPSS
- GHSA-88xg-v53p-fpvf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences