Read the docs
TI-2025-29277 Aliases CVE-2025-46560GHSA-vc6m-hm49-g9qg

vLLM phi4mm: Quadratic Time Complexity in Input Token Processing​ leads to denial of service

Priority HIGH 66CWE-1333Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1333.

Summary

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.8.0 and prior to 0.8.5 are affected by a critical performance vulnerability in the input preprocessing logic of the multimodal tokenizer. The code dynamically replaces placeholder tokens (e.g., <|audio_|>, <|image_|>) with repeated tokens based on precomputed lengths. Due to ​​inefficient list concatenation operations​​, the algorithm exhibits ​​quadratic time complexity (O(n²))​​, allowing malicious actors to trigger resource exhaustion via specially crafted inputs. This issue has been patched in version 0.8.5.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00533 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vllm (vllm-project): 0.8.5vllm (PyPI): 0.8.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vllm-projectvllm0.8.0 to before 0.8.50.8.5Patch availableCNA
—vllm (PyPI)0.8.0 to before 0.8.50.8.5Patch availableGHSA-vc6m-hm49-g9qg
  • vllm Vendorvllm-project Affected 0.8.0 to before 0.8.5 Fixed in 0.8.5 Patch available CNA
  • vllm (PyPI) Vendor— Affected 0.8.0 to before 0.8.5 Fixed in 0.8.5 Patch available GHSA-vc6m-hm49-g9qg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*0.8.0 to before 0.8.5VulnerablevLLM
  • cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:* Versions 0.8.0 to before 0.8.5 Vulnerable ·vLLM

Remediation

  • Fix · CNA vllm (vllm-project) Fixed in 0.8.5
  • Fix · GHSA-vc6m-hm49-g9qg vllm (PyPI) Fixed in 0.8.5 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat Enterprise Linux AI (RHEL AI)

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-46560
  2. 2026-10-03 Alias added: GHSA-vc6m-hm49-g9qg

References

  • TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
  • TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
  • TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
  • TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
  • TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
  • TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
See all 124 →

Sources