Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Auth0-PHP provides the PHP SDK for Auth0 Authentication and Management APIs. Starting in version 8.0.0-BETA1 and prior to version 8.14.0, session cookies of applications using the Auth0-PHP SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. Certain pre-conditions are required to be vulnerable to this issue: Applications using the Auth0-PHP SDK, or the Auth0/symfony, Auth0/laravel-auth0, and Auth0/wordpress SDKs that rely on the Auth0-PHP SDK; and session storage configured with CookieStore. Upgrade Auth0/Auth0-PHP to v8.14.0 to receive a patch. As an additional precautionary measure, rotating cookie encryption keys is recommended. Note that once updated, any previous session cookies will be rejected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| auth0 | auth0-PHP | 8.0.0-BETA1 to before 8.14.0 | 8.14.0 | Patch available | CNA |
| — | auth0/auth0-php (Packagist) | 8.0.0-BETA1 to before 8.14.0 | 8.14.0 | Patch available | GHSA-g98g-r7gf-2r25 |
- auth0-PHP Vendorauth0 Affected 8.0.0-BETA1 to before 8.14.0 Fixed in 8.14.0 Patch available CNA
- auth0/auth0-php (Packagist) Vendor— Affected 8.0.0-BETA1 to before 8.14.0 Fixed in 8.14.0 Patch available GHSA-g98g-r7gf-2r25
Remediation
- Fix · CNA auth0-PHP (auth0) Fixed in 8.14.0
- Fix · GHSA-g98g-r7gf-2r25 auth0/auth0-php (Packagist) Fixed in 8.14.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47275
- 2026-10-03 Alias added: GHSA-g98g-r7gf-2r25
References
Other 7
- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-g98g-r7gf-2r25
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-9fwj-9mjf-rhj3
- https://github.com/auth0/symfony/security/advisories/GHSA-9wg9-93h9-j8ch
- https://github.com/auth0/wordpress/security/advisories/GHSA-2f4r-34m4-3w8q
- https://github.com/auth0/auth0-PHP/commit/52a79480fdb246f59dbc089b81a784ae049bd389
- https://github.com/auth0/auth0-PHP/releases/tag/8.14.0
- https://github.com/auth0/auth0-PHP
More auth0 vulnerabilities
- TI-2015-07615 Improper input validation in HackerOne jsonwebtoken node module CVSS 3.0CRITICAL 9.8
- TI-2025-31089 Auth0-PHP SDK Deserialization of Untrusted Data vulnerability CVSS 4.0CRITICAL 9.3
- TI-2020-06427 An issue was discovered in the Login by Auth0 plugin before 4.0.0 for WordPress. CVSS 3.1CRITICAL 9.8
- TI-2018-05020 The Auth0 authentication service before 2017-10-15 allows privilege escalation because… CVSS 3.0CRITICAL 9.8
- TI-2019-05387 Auth0 Auth0-WCF-Service-JWT before 1.0.4 leaks the expected JWT signature in an error… CVSS 3.0CRITICAL 9.8
- TI-2026-26531 Auth0 PHP SDK Insufficient Entropy in Cookie Encryption CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-47275 · CVE Program
- CVE-2025-47275 · NVD
- FIRST EPSS
- GHSA-g98g-r7gf-2r25 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences