Auth0-PHP SDK Deserialization of Untrusted Data vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. Versions 8.0.0-BETA3 prior to 8.3.1 contain a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Applications using the Auth0-PHP SDK are affected, as are applications using the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs, because those SDKsrely on the Auth0-PHP SDK versions from 8.0.0-BETA3 until 8.14.0. Version 8.3.1 contains a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| auth0 | auth0-PHP | 8.0.0-BETA3 to before 8.3.1 | 8.3.1 | Patch available | CNA |
| — | auth0/auth0-php (Packagist) | 8.0.0-BETA3 to before 8.3.1 | 8.3.1 | Patch available | GHSA-v9m8-9xxp-q492 |
- auth0-PHP Vendorauth0 Affected 8.0.0-BETA3 to before 8.3.1 Fixed in 8.3.1 Patch available CNA
- auth0/auth0-php (Packagist) Vendor— Affected 8.0.0-BETA3 to before 8.3.1 Fixed in 8.3.1 Patch available GHSA-v9m8-9xxp-q492
Remediation
- Fix · CNA auth0-PHP (auth0) Fixed in 8.3.1
- Fix · GHSA-v9m8-9xxp-q492 auth0/auth0-php (Packagist) Fixed in 8.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-48951
- 2026-10-03 Alias added: GHSA-v9m8-9xxp-q492
References
Other 6
- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-v9m8-9xxp-q492
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-c42h-56wx-h85q
- https://github.com/auth0/symfony/security/advisories/GHSA-98j6-67v3-mw34
- https://github.com/auth0/wordpress/security/advisories/GHSA-862m-5253-832r
- https://github.com/auth0/auth0-PHP/commit/04b1f5daa8bdfebc5e740ec5ca0fb2df1648a715
- https://github.com/auth0/auth0-PHP
More auth0 vulnerabilities
- TI-2015-07615 Improper input validation in HackerOne jsonwebtoken node module CVSS 3.0CRITICAL 9.8
- TI-2025-29805 Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK CVSS 3.1CRITICAL 9.1
- TI-2020-06427 An issue was discovered in the Login by Auth0 plugin before 4.0.0 for WordPress. CVSS 3.1CRITICAL 9.8
- TI-2018-05020 The Auth0 authentication service before 2017-10-15 allows privilege escalation because… CVSS 3.0CRITICAL 9.8
- TI-2019-05387 Auth0 Auth0-WCF-Service-JWT before 1.0.4 leaks the expected JWT signature in an error… CVSS 3.0CRITICAL 9.8
- TI-2026-26531 Auth0 PHP SDK Insufficient Entropy in Cookie Encryption CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-48951 · CVE Program
- CVE-2025-48951 · NVD
- FIRST EPSS
- GHSA-v9m8-9xxp-q492 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences