Cross-site request forgery in Apache Geode
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user. This issue affects Apache Geode: versions 1.10 through 1.15.1 Users are recommended to upgrade to version 1.15.2, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Geode | 1.10.0 to before 1.15.2 | 1.15.2 | Patch available | CNA |
| — | org.apache.geode:geode-web (Maven) | 1.10.0 to before 1.15.2 | 1.15.2 | Patch available | GHSA-gjp8-99fv-cgcw |
- Apache Geode VendorApache Affected 1.10.0 to before 1.15.2 Fixed in 1.15.2 Patch available CNA
- org.apache.geode:geode-web (Maven) Vendor— Affected 1.10.0 to before 1.15.2 Fixed in 1.15.2 Patch available GHSA-gjp8-99fv-cgcw
Remediation
- Fix · CNA Apache Geode (Apache Software Foundation) Fixed in 1.15.2
- Fix · GHSA-gjp8-99fv-cgcw org.apache.geode:geode-web (Maven) Fixed in 1.15.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47410
- 2026-10-03 Alias added: GHSA-gjp8-99fv-cgcw
References
More Apache Geode vulnerabilities
- TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2019-11833 Docker Desktop Community Edition before 2.1.0.1 allows local users to gain privileges by… KEVCVSS 3.1HIGH 7.8
- TI-2019-11096 Information disclosure in Red Hat jackson-databind CVSS 3.1CRITICAL 9.8
- TI-2014-00046 Improper input validation in docker.io CVSS 3.1CRITICAL 9.8
- TI-2017-11466 Deserialization of untrusted data in Apache Geode CVSS 3.0CRITICAL 9.8
- TI-2022-17225 Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-47410 · CVE Program
- CVE-2025-47410 · NVD
- FIRST EPSS
- GHSA-gjp8-99fv-cgcw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences