5ire Client Vulnerable to Cross-Site Scripting (XSS) and Remote Code Execution (RCE)
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Versions prior to 0.11.1 are vulnerable to stored cross-site scripting in chatbot responses due to insufficient sanitization. This, in turn, can lead to Remote Code Execution (RCE) via unsafe Electron protocol handling and exposed Electron APIs. All users of 5ire client versions prior to patched releases, particularly those interacting with untrusted chatbots or pasting external content, are affected. Version 0.11.1 contains a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nanbingxyz | 5ire | before 0.11.1 | 0.11.1 | Patch available | CNA |
- 5ire Vendornanbingxyz Affected before 0.11.1 Fixed in 0.11.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:5ire:5ire:*:*:*:*:*:*:*:* | before 0.11.1 | Vulnerable | nanbingxyz |
- cpe:2.3:a:5ire:5ire:*:*:*:*:*:*:*:* Versions before 0.11.1 Vulnerable ·nanbingxyz
Remediation
- Fix · CNA 5ire (nanbingxyz) Fixed in 0.11.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47777
References
More nanbingxyz 5ire vulnerabilities
- TI-2026-18311 5ire vulnerable to Remote Code Execution (RCE) via ECharts CVSS 3.1CRITICAL 9.7
- TI-2026-18310 5ire vulnerable to Remote Code Execution (RCE) CVSS 3.1CRITICAL 9.7
- TI-2025-42162 5ire vulnerable to Remote Code Execution (RCE) via mermaid CVSS 3.1CRITICAL 9.7
- TI-2025-36146 5ire Chat Message XSS Vulnerability Enables Remote Code Execution CVSS 3.1CRITICAL 9.7
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences