5ire vulnerable to Remote Code Execution (RCE) via ECharts
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-94.
Summary
5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Prior to version 0.15.3, an unsafe option parsing vulnerability in the ECharts Markdown plugin allows any user able to submit ECharts code blocks to execute arbitrary JavaScript code in the renderer context. This can lead to Remote Code Execution (RCE) in environments where privileged APIs (such as Electron’s electron.mcp) are exposed, resulting in full compromise of the host system. Version 0.15.3 patches the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nanbingxyz | 5ire | before 0.15.3 | 0.15.3 | Patch available | CNA |
- 5ire Vendornanbingxyz Affected before 0.15.3 Fixed in 0.15.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:5ire:5ire:*:*:*:*:*:*:*:* | before 0.15.3 | Vulnerable | nanbingxyz |
- cpe:2.3:a:5ire:5ire:*:*:*:*:*:*:*:* Versions before 0.15.3 Vulnerable ·nanbingxyz
Remediation
- Fix · CNA 5ire (nanbingxyz) Fixed in 0.15.3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22793
References
More nanbingxyz 5ire vulnerabilities
- TI-2026-18310 5ire vulnerable to Remote Code Execution (RCE) CVSS 3.1CRITICAL 9.7
- TI-2025-42162 5ire vulnerable to Remote Code Execution (RCE) via mermaid CVSS 3.1CRITICAL 9.7
- TI-2025-36146 5ire Chat Message XSS Vulnerability Enables Remote Code Execution CVSS 3.1CRITICAL 9.7
- TI-2025-30242 5ire Client Vulnerable to Cross-Site Scripting (XSS) and Remote Code Execution (RCE) CVSS 3.1CRITICAL 9.7
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences