5ire Chat Message XSS Vulnerability Enables Remote Code Execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Version 0.13.2 contains a vulnerability in the chat page's script gadgets that enables content injection attacks through multiple vectors: malicious prompt injection pages, compromised MCP servers, and exploited tool integrations. This is fixed in version 0.14.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nanbingxyz | 5ire | 0.13.2 to before 0.14.0 | 0.14.0 | Patch available | CNA |
- 5ire Vendornanbingxyz Affected 0.13.2 to before 0.14.0 Fixed in 0.14.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:5ire:5ire:0.13.2:*:*:*:*:*:*:* | 0.13.2 | Vulnerable | nanbingxyz |
- cpe:2.3:a:5ire:5ire:0.13.2:*:*:*:*:*:*:* Versions 0.13.2 Vulnerable ·nanbingxyz
Remediation
- Fix · CNA 5ire (nanbingxyz) Fixed in 0.14.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-58357
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More nanbingxyz 5ire vulnerabilities
- TI-2026-18311 5ire vulnerable to Remote Code Execution (RCE) via ECharts CVSS 3.1CRITICAL 9.7
- TI-2026-18310 5ire vulnerable to Remote Code Execution (RCE) CVSS 3.1CRITICAL 9.7
- TI-2025-42162 5ire vulnerable to Remote Code Execution (RCE) via mermaid CVSS 3.1CRITICAL 9.7
- TI-2025-30242 5ire Client Vulnerable to Cross-Site Scripting (XSS) and Remote Code Execution (RCE) CVSS 3.1CRITICAL 9.7
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences