Multer vulnerable to Denial of Service from maliciously crafted requests
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-248.
Summary
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| expressjs | multer | 1.4.4-lts.1 to before 2.0.0 | 2.0.0 | Patch available | CNA |
| — | multer (npm) | 1.4.4-lts.1 to before 2.0.0 | 2.0.0 | Patch available | GHSA-4pg4-qvpc-4q3h |
- multer Vendorexpressjs Affected 1.4.4-lts.1 to before 2.0.0 Fixed in 2.0.0 Patch available CNA
- multer (npm) Vendor— Affected 1.4.4-lts.1 to before 2.0.0 Fixed in 2.0.0 Patch available GHSA-4pg4-qvpc-4q3h
Remediation
- Fix · CNA multer (expressjs) Fixed in 2.0.0
- Fix · GHSA-4pg4-qvpc-4q3h multer (npm) Fixed in 2.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47944
- 2026-10-03 Alias added: GHSA-4pg4-qvpc-4q3h
References
More expressjs vulnerabilities
- TI-2024-08602 Open redirect in expressjs express CVSS 3.1MEDIUM 4.7
- TI-2026-03033 Multer vulnerable to Denial of Service via uncontrolled recursion CVSS 4.0HIGH 8.7
- TI-2026-02853 Multer vulnerable to Denial of Service via incomplete cleanup CVSS 4.0HIGH 8.7
- TI-2026-01995 Multer vulnerable to Denial of Service via resource exhaustion CVSS 4.0HIGH 8.7
- TI-2025-31125 Multer vulnerable to Denial of Service via unhandled exception CVSS 4.0HIGH 8.7
- TI-2025-30328 Multer vulnerable to Denial of Service via memory leaks from unclosed streams CVSS 3.1HIGH 7.5
Sources
- CVE-2025-47944 · CVE Program
- CVE-2025-47944 · NVD
- FIRST EPSS
- GHSA-4pg4-qvpc-4q3h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences