Read the docs
TI-2026-02853 Aliases CVE-2026-3304GHSA-xf7r-hgr6-v32p

Multer vulnerable to Denial of Service via incomplete cleanup

Priority MEDIUM 45CWE-459Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 2 fixed, 1 without a fix

Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat.

Summary

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00738 54th percentileScored 2026-11-07
Fix Partial multer (expressjs): 2.1.0multer (npm): 2.1.0Red Hat: 2 advisoriesRed Hat: 2 fixed, 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
expressjsmulter0.0.0 to before 2.1.02.1.0Patch availableCNA
—multer (npm)before 2.1.02.1.0Patch availableGHSA-xf7r-hgr6-v32p
  • multer Vendorexpressjs Affected 0.0.0 to before 2.1.0 Fixed in 2.1.0 Patch available CNA
  • multer (npm) Vendor— Affected before 2.1.0 Fixed in 2.1.0 Patch available GHSA-xf7r-hgr6-v32p

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:expressjs:multer:*:*:*:*:*:node.js:*:*before 2.1.0Vulnerableexpressjs
  • cpe:2.3:a:expressjs:multer:*:*:*:*:*:node.js:*:* Versions before 2.1.0 Vulnerable ·expressjs

Remediation

  • Fix · CNA multer (expressjs) Fixed in 2.1.0
  • Fix · GHSA-xf7r-hgr6-v32p multer (npm) Fixed in 2.1.0 Advisory →

Red Hat 2 advisories

  • RHSA-2026:6802 Released 2026-04-07 · Red Hat rating Important
    Red Hat Developer Hub 1.9.3 release.
    • Red Hat Developer Hub 1.9 registry.redhat.io/rhdh/rhdh-hub-rhel9, registry.redhat.io/rhdh/rhdh-rhel9-operator
  • RHSA-2026:6174 Released 2026-03-30 · Red Hat rating Important
    Red Hat Developer Hub 1.8.5 release.
    • Red Hat Developer Hub 1.8 registry.redhat.io/rhdh/rhdh-hub-rhel9, registry.redhat.io/rhdh/rhdh-rhel9-operator

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    expressjs multer 2.1.0

    2 records Highest priority Priority MEDIUM 2 MEDIUM

    Other records, highest priority first

    • TI-2026-01995 Multer vulnerable to Denial of Service via resource exhaustionPriority MEDIUM 45

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Self-service automation portal 2AffectedNo fix yet
Red Hat Developer Hub 1.8Fixed RHSA-2026:6174
Red Hat Developer Hub 1.9Fixed RHSA-2026:6802
Not affected: 8 products
  • Logging Subsystem for Red Hat OpenShift
  • Red Hat Developer Hub 1.8
  • Red Hat Developer Hub 1.9
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat Trusted Profile Analyzer

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-3304
  2. 2026-10-03 Alias added: GHSA-xf7r-hgr6-v32p

References

  • TI-2026-03033 Multer vulnerable to Denial of Service via uncontrolled recursion CVSS 4.0HIGH 8.7
  • TI-2026-01995 Multer vulnerable to Denial of Service via resource exhaustion CVSS 4.0HIGH 8.7
  • TI-2026-56780 multer vulnerable to Denial of Service via oversized array index in field names CVSS 3.1HIGH 7.5
  • TI-2026-53831 multer vulnerable to Denial of Service via crafted multipart field names CVSS 3.1HIGH 7.5
  • TI-2026-53816 multer vulnerable to Denial of Service via file descriptor leak on aborted uploads CVSS 3.1HIGH 7.5
  • TI-2026-04434 multer vulnerable to Denial of Service via deeply nested field names CVSS 3.1HIGH 7.5
See all 8 →

Sources