MyBB's upgrade component vulnerable to local file inclusion
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
MyBB is free and open source forum software. Prior to version 1.8.39, the upgrade component does not validate user input properly, which allows attackers to perform local file inclusion (LFI) via a specially crafted parameter value. In order to exploit the vulnerability, the installer must be unlocked (no `install/lock` file present) and the upgrade script must be accessible (by re-installing the forum via access to `install/index.php`; when the forum has not yet been installed; or the attacker is authenticated as a forum administrator). MyBB 1.8.39 resolves this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA mybb (mybb) Fixed in 1.8.39
Timeline
- 2026-10-02 Threatist record created from CVE-2025-48940
References
More Mybb vulnerabilities
- TI-2011-04621 myBB 1.6.4 Backdoor Arbitrary Command Execution CVSS 4.0CRITICAL 10.0
- TI-2022-08548 Remote code execution in mybb CVSS 3.1HIGH 7.2
- TI-2023-21959 MyBB before 1.8.36 allows Code Injection by users with certain high privileges. CVSS 3.1HIGH 7.2
- TI-2022-18641 Mail settings' command parameter injection in mybb CVSS 3.1HIGH 7.2
- TI-2025-21092 An issue in MyBB 1.8.38 allows a remote attacker to obtain sensitive information via the… CVSS 3.1HIGH 7.6
- TI-2025-21091 An issue in MyBB 1.8.38 allows a remote attacker to obtain sensitive information via the… CVSS 3.1HIGH 7.6
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences