Read the docs
TI-2025-31080 Aliases CVE-2025-48942GHSA-6qc9-v4r8-22xg

vLLM DOS: Remotely kill vllm over http with invalid JSON schema

Priority MEDIUM 62CWE-248Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 2 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-248.

Summary

vLLM is an inference and serving engine for large language models (LLMs). In versions 0.8.0 up to but excluding 0.9.0, hitting the /v1/completions API with a invalid json_schema as a Guided Param kills the vllm server. This vulnerability is similar GHSA-9hcf-v7m4-6m2j/CVE-2025-48943, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00575 47th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial vllm (vllm-project): 0.9.0vllm (PyPI): 0.9.0Red Hat: 2 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vllm-projectvllm0.8.0 to before 0.9.00.9.0Patch availableCNA
—vllm (PyPI)0.8.0 to before 0.9.00.9.0Patch availableGHSA-6qc9-v4r8-22xg
  • vllm Vendorvllm-project Affected 0.8.0 to before 0.9.0 Fixed in 0.9.0 Patch available CNA
  • vllm (PyPI) Vendor— Affected 0.8.0 to before 0.9.0 Fixed in 0.9.0 Patch available GHSA-6qc9-v4r8-22xg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*0.8.0 to before 0.9.0VulnerablevLLM
  • cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:* Versions 0.8.0 to before 0.9.0 Vulnerable ·vLLM

Remediation

  • Fix · CNA vllm (vllm-project) Fixed in 0.9.0
  • Fix · GHSA-6qc9-v4r8-22xg vllm (PyPI) Fixed in 0.9.0 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat AI Inference ServerAffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux AI (RHEL AI)AffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-48942
  2. 2026-10-03 Alias added: GHSA-6qc9-v4r8-22xg

References

  • TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
  • TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
  • TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
  • TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
  • TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
  • TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
See all 124 →

Sources