WordPress Login/Signup Popup plugin <= 2.9.4 - Cross Site Scripting (XSS) Vulnerability
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in xootix Login/Signup Popup easy-login-woocommerce allows Stored XSS.This issue affects Login/Signup Popup: from n/a through <= 2.9.4.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00256 17th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-50027
- 2026-10-03 Alias added: GHSA-wq62-x3x3-66p4
More xootix vulnerabilities
- TI-2024-04943 XootiX Framework <= Various Plugin Versions - Missing Authorization to Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2022-00152 XootiX Plugins <= Various Versions Cross-Site Request Forgery to Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2023-02534 OTP Login Woocommerce & Gravity Forms <= 2.2 - Authentication Bypass to Privilege Escalation CVSS 3.1HIGH 8.1
- TI-2022-22342 WordPress Side Cart Woocommerce (Ajax) Plugin < 2.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2020-18886 Login/Signup Popup < 1.5 - Missing Authorization CVSS 3.1HIGH 7.4
- TI-2026-10507 OTP Login & Register Woocommerce <= 2.7.2 - Unauthenticated Authentication Bypass via Brute Force CVSS 3.1MEDIUM 5.3
Sources
- CVE-2025-50027 · CVE Program
- CVE-2025-50027 · NVD
- FIRST EPSS
- GHSA-wq62-x3x3-66p4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences