Cross-site scripting in vercel Nuxt Devtools
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability in Nuxt DevTools has been fixed in version **2.6.4***. This issue may have allowed Nuxt auth token extraction via XSS under certain configurations. All users are encouraged to upgrade. More details: https://vercel.com/changelog/cve-2025-52662-xss-on-nuxt-devtools
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00254 16th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed @nuxt/devtools (npm): 2.6.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vercel | Nuxt Devtools | 2.6.3 – 2.6.3 | — | No fix listed | CNA |
| — | @nuxt/devtools (npm) | before 2.6.4 | 2.6.4 | Patch available | GHSA-xmq3-q5pm-rp26 |
- Nuxt Devtools Vendorvercel Affected 2.6.3 – 2.6.3 Fixed in — No fix listed CNA
- @nuxt/devtools (npm) Vendor— Affected before 2.6.4 Fixed in 2.6.4 Patch available GHSA-xmq3-q5pm-rp26
Remediation
- Fix · GHSA-xmq3-q5pm-rp26 @nuxt/devtools (npm) Fixed in 2.6.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-52662
- 2026-10-03 Alias added: GHSA-xmq3-q5pm-rp26
References
More vercel vulnerabilities
- TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
- TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
- TI-2024-15745 An issue in Hyper on macOS version 3.4.1 and before, allows remote attackers to execute… CVSS 3.1CRITICAL 9.8
- TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
- TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
- TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
Sources
- CVE-2025-52662 · CVE Program
- CVE-2025-52662 · NVD
- FIRST EPSS
- GHSA-xmq3-q5pm-rp26 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences