CSRF Vulnerability When Using Client Certificate Authentication with the LXD-UI
Priority LOW 34CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Cross-Site Request Forgery (CSRF) in LXD-UI in Canonical LXD versions >= 5.0 on Linux allows an attacker to create and start container instances without user consent via crafted HTML form submissions exploiting client certificate authentication.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00127 2nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed LXD (Canonical): 5.0.5, 5.21.4, 6.5github.com/canonical/lxd (Go): 5.0.5, 5.21.4, 6.5 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | LXD | 5.0 to before 5.0.5; 5.21 to before 5.21.4; 6.0 to before 6.5 | 5.0.5, 5.21.4, 6.5 | Patch available | CNA |
| — | github.com/canonical/lxd (Go) | 5.0 to before 5.0.5 | 5.0.5 | Patch available | GHSA-p8hw-rfjg-689h |
| — | github.com/canonical/lxd (Go) | 5.1 to before 5.21.4 | 5.21.4 | Patch available | GHSA-p8hw-rfjg-689h |
| — | github.com/canonical/lxd (Go) | 6.0 to before 6.5 | 6.5 | Patch available | GHSA-p8hw-rfjg-689h |
| — | github.com/canonical/lxd (Go) | 0.0.0-20220401034332-1e1349e3cbf3 to before 0.0.0-20250827065555-0494f5d47e41 | 0.0.0-20250827065555-0494f5d47e41 | Patch available | GHSA-p8hw-rfjg-689h |
- LXD VendorCanonical Affected 5.0 to before 5.0.5; 5.21 to before 5.21.4; 6.0 to before 6.5 Fixed in 5.0.5, 5.21.4, 6.5 Patch available CNA
- github.com/canonical/lxd (Go) Vendor— Affected 5.0 to before 5.0.5 Fixed in 5.0.5 Patch available GHSA-p8hw-rfjg-689h
- github.com/canonical/lxd (Go) Vendor— Affected 5.1 to before 5.21.4 Fixed in 5.21.4 Patch available GHSA-p8hw-rfjg-689h
- github.com/canonical/lxd (Go) Vendor— Affected 6.0 to before 6.5 Fixed in 6.5 Patch available GHSA-p8hw-rfjg-689h
- github.com/canonical/lxd (Go) Vendor— Affected 0.0.0-20220401034332-1e1349e3cbf3 to before 0.0.0-20250827065555-0494f5d47e41 Fixed in 0.0.0-20250827065555-0494f5d47e41 Patch available GHSA-p8hw-rfjg-689h
Remediation
- Fix · CNA LXD (Canonical) Fixed in 5.0.5, 5.21.4, 6.5
- Fix · GHSA-p8hw-rfjg-689h github.com/canonical/lxd (Go) Fixed in 5.0.5 Advisory →
- Fix · GHSA-p8hw-rfjg-689h github.com/canonical/lxd (Go) Fixed in 5.21.4 Advisory →
- Fix · GHSA-p8hw-rfjg-689h github.com/canonical/lxd (Go) Fixed in 6.5 Advisory →
- Fix · GHSA-p8hw-rfjg-689h github.com/canonical/lxd (Go) Fixed in 0.0.0-20250827065555-0494f5d47e41 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54286
- 2026-10-03 Alias added: GHSA-p8hw-rfjg-689h
References
More Canonical Lxd vulnerabilities
- TI-2026-22659 Authenticated RCE via unsanitized compression_algorithm CVSS 4.0CRITICAL 9.4
- TI-2026-47475 Path traversal via unvalidated instance name in backup tarball restore enables root file write / RCE CVSS 3.1CRITICAL 9.9
- TI-2026-45146 Cross-project instance move bypasses all project restrictions allowing host command execution CVSS 3.1CRITICAL 9.9
- TI-2026-45143 Cross-project instance copy bypasses target project restrictions via TOCTOU in config merge CVSS 3.1CRITICAL 9.9
- TI-2026-45142 Project restriction bypass via instance migration config override CVSS 3.1CRITICAL 9.9
- TI-2026-45140 Root RCE via image backup.yaml symlink CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-54286 · CVE Program
- CVE-2025-54286 · NVD
- FIRST EPSS
- GHSA-p8hw-rfjg-689h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences