Craft contains a theoretical bypass for CVE-2025-23209
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | 4.13.8 to before 4.16.3; 5.5.8 to before 5.8.4 | 4.16.3, 5.8.4 | Patch available | CNA |
| — | craftcms/cms (Packagist) | 4.13.8 to before 4.16.3 | 4.16.3 | Patch available | GHSA-2vcf-qxv3-2mgw |
| — | craftcms/cms (Packagist) | 5.5.8 to before 5.8.4 | 5.8.4 | Patch available | GHSA-2vcf-qxv3-2mgw |
- cms VendorCraft CMS Affected 4.13.8 to before 4.16.3; 5.5.8 to before 5.8.4 Fixed in 4.16.3, 5.8.4 Patch available CNA
- craftcms/cms (Packagist) Vendor— Affected 4.13.8 to before 4.16.3 Fixed in 4.16.3 Patch available GHSA-2vcf-qxv3-2mgw
- craftcms/cms (Packagist) Vendor— Affected 5.5.8 to before 5.8.4 Fixed in 5.8.4 Patch available GHSA-2vcf-qxv3-2mgw
Remediation
- Fix · CNA cms (craftcms) Fixed in 4.16.3, 5.8.4
- Fix · GHSA-2vcf-qxv3-2mgw craftcms/cms (Packagist) Fixed in 4.16.3 Advisory →
- Fix · GHSA-2vcf-qxv3-2mgw craftcms/cms (Packagist) Fixed in 5.8.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54417
- 2026-10-03 Alias added: GHSA-2vcf-qxv3-2mgw
References
More Craft Cms vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-54417 · CVE Program
- CVE-2025-54417 · NVD
- FIRST EPSS
- GHSA-2vcf-qxv3-2mgw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences