Read the docs
TI-2025-34710 Aliases CVE-2025-55007

Knowage vulnerable to server-side request forgery

Priority LOW 23CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-918 and the CVSS impact.

Summary

Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, Knowage is vulnerable to server-side request forgery. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker could be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00193 9th percentileScored 2026-11-07
Fix Fixed Knowage-Server (KnowageLabs): 8.1.37

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
KnowageLabsKnowage-Serverbefore 8.1.378.1.37Patch availableCNA
  • Knowage-Server VendorKnowageLabs Affected before 8.1.37 Fixed in 8.1.37 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:*before 8.1.37VulnerableKnowageLabs
  • cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:* Versions before 8.1.37 Vulnerable ·KnowageLabs

Remediation

  • Fix · CNA Knowage-Server (KnowageLabs) Fixed in 8.1.37

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-55007

References

  • TI-2025-37342 Knowage Contains a Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.3
  • TI-2023-20050 Knowage Server vulnerable to path traversal via upload functionality CVSS 3.1CRITICAL 10.0
  • TI-2023-17600 Knowage-Server vulnerable to account validation bypass CVSS 3.1HIGH 7.2
  • TI-2023-19080 Query injection in Knowage server CVSS 3.1HIGH 7.7
  • TI-2023-18613 Knowage-Server vulnerable to Path traversal in download functionalities CVSS 3.1MEDIUM 6.5
  • TI-2022-18671 Improper Neutralization of Alternate XSS Syntax in Knowage-Server CVSS 3.1MEDIUM 6.1
See all 20 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences