Read the docs
TI-2025-36671 Aliases CVE-2025-59029GHSA-2gr2-cm9q-vr3v

Internal logic flaw in cache management can lead to a denial of service in PowerDNS Recursor

Priority LOW 30CWE-617Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-617.

Summary

An attacker can trigger an assertion failure by requesting crafted DNS records, waiting for them to be inserted into the records cache, then send a query with qtype set to ANY.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00374 31st percentileScored 2026-11-07
Fix Fixed Recursor (PowerDNS): 5.3.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PowerDNSRecursor5.3.0 to before 5.3.25.3.2Patch availableCNA
  • Recursor VendorPowerDNS Affected 5.3.0 to before 5.3.2 Fixed in 5.3.2 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:powerdns:recursor:5.3.0:-:*:*:*:*:*:*5.3.0VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:5.3.1:*:*:*:*:*:*:*5.3.1VulnerablePowerDNS
  • cpe:2.3:a:powerdns:recursor:5.3.0:-:*:*:*:*:*:* Versions 5.3.0 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:5.3.1:*:*:*:*:*:*:* Versions 5.3.1 Vulnerable ·PowerDNS

Remediation

  • Fix · CNA Recursor (PowerDNS) Fixed in 5.3.2

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-59029
  2. 2026-10-03 Alias added: GHSA-2gr2-cm9q-vr3v

References

  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
  • TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
  • TI-2017-11091 NULL pointer dereference in PowerDNS pdns-recursor CVSS 3.0HIGH 7.5
  • TI-2014-07065 PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote… CVSS 2.0MEDIUM 5.0
See all 49 →

Sources