Read the docs
TI-2025-36672 Aliases CVE-2025-59030GHSA-646x-553g-6v9h

Insufficient validation of incoming notifies over TCP can lead to a denial of service in Recursor

Priority MEDIUM 40CWE-276Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

An attacker can trigger the removal of cached records by sending a NOTIFY query over TCP.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00585 48th percentileScored 2026-11-07
Fix Fixed Recursor (PowerDNS): 5.3.3, 5.2.7, 5.1.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PowerDNSRecursor5.3.0 to before 5.3.3; 5.2.0 to before 5.2.7; 5.1.0 to before 5.1.95.3.3, 5.2.7, 5.1.9Patch availableCNA
  • Recursor VendorPowerDNS Affected 5.3.0 to before 5.3.3; 5.2.0 to before 5.2.7; 5.1.0 to before 5.1.9 Fixed in 5.3.3, 5.2.7, 5.1.9 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:*5.1.0 to before 5.1.9; 5.2.0 to before 5.2.7; 5.3.0 to before 5.3.3VulnerablePowerDNS
  • cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:* Versions 5.1.0 to before 5.1.9; 5.2.0 to before 5.2.7; 5.3.0 to before 5.3.3 Vulnerable ·PowerDNS

Remediation

  • Fix · CNA Recursor (PowerDNS) Fixed in 5.3.3, 5.2.7, 5.1.9

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-59030
  2. 2026-10-03 Alias added: GHSA-646x-553g-6v9h

References

  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
  • TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
  • TI-2017-11091 NULL pointer dereference in PowerDNS pdns-recursor CVSS 3.0HIGH 7.5
  • TI-2014-07065 PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote… CVSS 2.0MEDIUM 5.0
See all 49 →

Sources