Read the docs
TI-2025-37021 Aliases CVE-2025-59476GHSA-qrh5-jg98-cr48

Injection in Jenkins

Priority LOW 30CWE-117Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.

Summary

Jenkins 2.527 and earlier, LTS 2.516.2 and earlier does not restrict or transform the characters that can be inserted from user-specified content in log messages, allowing attackers able to control log message contents to insert line break characters, followed by forged log messages that may mislead administrators reviewing log output.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0038 32nd percentileScored 2026-11-07
Fix Partial Jenkins (Jenkins Project): 2.516.3, 2.528org.jenkins-ci.main:jenkins-core (Maven): 2.516.3, 2.528Red Hat: 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins—2.516.3, 2.528Patch availableCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.516.32.516.3Patch availableGHSA-qrh5-jg98-cr48
—org.jenkins-ci.main:jenkins-core (Maven)2.517 to before 2.5282.528Patch availableGHSA-qrh5-jg98-cr48
  • Jenkins VendorJenkins Affected — Fixed in 2.516.3, 2.528 Patch available CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.516.3 Fixed in 2.516.3 Patch available GHSA-qrh5-jg98-cr48
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.517 to before 2.528 Fixed in 2.528 Patch available GHSA-qrh5-jg98-cr48

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*before 2.516.3VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*before 2.528VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions before 2.516.3 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions before 2.528 Vulnerable ·Jenkins

Remediation

  • Fix · CNA Jenkins (Jenkins Project) Fixed in 2.516.3, 2.528
  • Fix · GHSA-qrh5-jg98-cr48 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.516.3 Advisory →
  • Fix · GHSA-qrh5-jg98-cr48 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.528 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Jenkins — Jenkins Security Advisory 2025-09-17

    3 records Highest priority Priority LOW 3 LOW

    Other records, highest priority first

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
OpenShift Developer Tools and ServicesAffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-59476
  2. 2026-10-03 Alias added: GHSA-qrh5-jg98-cr48

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources