Read the docs
TI-2025-37059 Aliases CVE-2025-59528GHSA-3gcm-f6qx-ff7p

Flowise has Remote Code Execution vulnerability

Priority CRITICAL 91CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5, Flowise is vulnerable to remote code execution. The CustomMCP node allows users to input configuration settings for connecting to an external MCP server. This node parses the user-provided mcpServerConfig string to build the MCP server configuration. However, during this process, it executes JavaScript code without any security validation. Specifically, inside the convertToValidJSONString function, user input is directly passed to the Function() constructor, which evaluates and executes the input as JavaScript code. Since this runs with full Node.js runtime privileges, it can access dangerous modules such as child_process and fs. This issue has been patched in version 3.0.6.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.86975 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed flowise (npm): 3.0.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
FlowiseAIFlowise= 3.0.5—No fix listedCNA
—flowise (npm)3.0.5 to before 3.0.63.0.6Patch availableGHSA-3gcm-f6qx-ff7p
  • Flowise VendorFlowiseAI Affected = 3.0.5 Fixed in — No fix listed CNA
  • flowise (npm) Vendor— Affected 3.0.5 to before 3.0.6 Fixed in 3.0.6 Patch available GHSA-3gcm-f6qx-ff7p

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:flowiseai:flowise:3.0.5:*:*:*:*:*:*:*3.0.5VulnerableFlowiseAI
  • cpe:2.3:a:flowiseai:flowise:3.0.5:*:*:*:*:*:*:* Versions 3.0.5 Vulnerable ·FlowiseAI

Remediation

  • Fix · GHSA-3gcm-f6qx-ff7p flowise (npm) Fixed in 3.0.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-59528
  2. 2026-10-03 Alias added: GHSA-3gcm-f6qx-ff7p

References

  • TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
  • TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
  • TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
  • TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
  • TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
  • TI-2025-19292 FlowiseAI Flowise v2.2.6 was discovered to contain an arbitrary file upload vulnerability in /api/v1/attachments. CVSS 3.1CRITICAL 9.8
See all 127 →

Sources