Flowise before 3.1.3 Sandbox Escape via Puppeteer
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Flowise (packages flowise and flowise-components) in versions <= 3.1.2 contain a sandbox escape in the vm2/@flowiseai/nodevm JavaScript sandbox. An authenticated user with access to the /api/v1/node-custom-function endpoint can escape the sandbox by supplying attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary OS commands as the Flowise process user (root in the official Docker image) and arbitrary host file disclosure via Chromium's file:// URL handling. In versions 3.0.8–3.1.2 exploitation requires ALLOW_BUILTIN_DEP=true; earlier versions are exploitable by default. Fixed in 3.1.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| FlowiseAI | Flowise | before 3.1.3 | 3.1.3 | Patch available | CNA |
| FlowiseAI | Flowise | before 3.1.3 | 3.1.3 | Patch available | CNA |
| — | flowise (npm) | before 3.1.3 | 3.1.3 | Patch available | GHSA-9gvv-qjj3-2p6g |
| — | flowise-components (npm) | before 3.1.3 | 3.1.3 | Patch available | GHSA-9gvv-qjj3-2p6g |
- Flowise VendorFlowiseAI Affected before 3.1.3 Fixed in 3.1.3 Patch available CNA
- Flowise VendorFlowiseAI Affected before 3.1.3 Fixed in 3.1.3 Patch available CNA
- flowise (npm) Vendor— Affected before 3.1.3 Fixed in 3.1.3 Patch available GHSA-9gvv-qjj3-2p6g
- flowise-components (npm) Vendor— Affected before 3.1.3 Fixed in 3.1.3 Patch available GHSA-9gvv-qjj3-2p6g
Remediation
- Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.3
- Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.3
- Fix · GHSA-9gvv-qjj3-2p6g flowise (npm) Fixed in 3.1.3 Advisory →
- Fix · GHSA-9gvv-qjj3-2p6g flowise-components (npm) Fixed in 3.1.3 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
FlowiseAI Flowise 3.1.3
9 records Highest priority Priority HIGH 4 HIGH, 5 MEDIUM
Other records, highest priority first
- TI-2026-51599 Flowise before 3.1.3 Prompt Injection RCE via CSV AgentPriority HIGH 80
- TI-2026-51598 Flowise before 3.1.3 Code Injection via CSV Agent customReadCSVPriority HIGH 74
- TI-2026-51596 Flowise before 3.1.3 Sandbox Escape via Pandas MethodsPriority HIGH 72
Timeline
- 2026-10-02 Threatist record created from CVE-2026-73483
- 2026-10-03 Alias added: GHSA-6j9g-8fxc-25hq
- 2026-10-07 Alias added: GHSA-9gvv-qjj3-2p6g
- 2026-10-07 Fix available: npm/[email protected], npm/[email protected] · GHSA-9gvv-qjj3-2p6g
- 2026-10-07 CVSS score added · GHSA-9gvv-qjj3-2p6g
- 2026-10-07 3 new references · GHSA-9gvv-qjj3-2p6g
- 2026-10-08 EPSS moved to the below the 50th percentile
- 2026-11-07 EPSS moved to the 50th–90th percentile
References
More FlowiseAI Flowise vulnerabilities
- TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
- TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
- TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
- TI-2025-19292 FlowiseAI Flowise v2.2.6 was discovered to contain an arbitrary file upload vulnerability in /api/v1/attachments. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-73483 · CVE Program
- CVE-2026-73483 · NVD
- FIRST EPSS
- GHSA-6j9g-8fxc-25hq · GitHub Advisory Database · CC BY 4.0
- GHSA-9gvv-qjj3-2p6g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences