Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, a prompt injection sent to a chatflow using a CSV Agent node can cause the LLM to respond with a malicious Python script that bypasses the blocklist validator and executes in an unsandboxed Pyodide environment. The specific flaw exists within the run method of the CSV_Agents class, where untrusted data is used to construct an LLM prompt and the resulting pythonCode is validated by validatePythonCodeForDataFrame before execution. An attacker can leverage this to execute arbitrary code in the context of the service account. This issue is fixed in 3.1.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| FlowiseAI | Flowise | before 3.1.2 | 3.1.2 | Patch available | CNA |
| — | flowise (npm) | before 3.1.3 | 3.1.3 | Patch available | GHSA-5xvg-pmgg-3mxr |
| — | flowise-components (npm) | before 3.1.3 | 3.1.3 | Patch available | GHSA-5xvg-pmgg-3mxr |
- Flowise VendorFlowiseAI Affected before 3.1.2 Fixed in 3.1.2 Patch available CNA
- flowise (npm) Vendor— Affected before 3.1.3 Fixed in 3.1.3 Patch available GHSA-5xvg-pmgg-3mxr
- flowise-components (npm) Vendor— Affected before 3.1.3 Fixed in 3.1.3 Patch available GHSA-5xvg-pmgg-3mxr
Remediation
- Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.2
- Fix · GHSA-5xvg-pmgg-3mxr flowise (npm) Fixed in 3.1.3 Advisory →
- Fix · GHSA-5xvg-pmgg-3mxr flowise-components (npm) Fixed in 3.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-70477
- 2026-10-03 Alias added: GHSA-5xvg-pmgg-3mxr
References
Patch 2
More FlowiseAI Flowise vulnerabilities
- TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
- TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
- TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
- TI-2025-19292 FlowiseAI Flowise v2.2.6 was discovered to contain an arbitrary file upload vulnerability in /api/v1/attachments. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-70477 · CVE Program
- CVE-2026-70477 · NVD
- FIRST EPSS
- GHSA-5xvg-pmgg-3mxr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences