Read the docs
TI-2025-37262 Aliases CVE-2025-59823GHSA-227x-7mh8-3cf6

Gardener providers vulnerable to code injection when Terraformer is used for infrastructure provisioning

Priority MEDIUM 43CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Project Gardener implements the automated management and operation of Kubernetes clusters as a service. Code injection may be possible in Gardener Extensions for AWS providers prior to version 1.64.0, Azure providers prior to version 1.55.0, OpenStack providers prior to version 1.49.0, and GCP providers prior to version 1.46.0. This vulnerability could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster where the shoot cluster is managed. This affects all Gardener installations where Terraformer is used/can be enabled for infrastructure provisioning with any of the affected components. This issue has been patched in Gardener Extensions for AWS providers version 1.64.0, Azure providers version 1.55.0, OpenStack providers version 1.49.0, and GCP providers version 1.46.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00493 42nd percentileScored 2026-11-07
Fix Fixed gardener-extension-provider-aws (gardener): 1.64.0, 1.55.0, 1.49.0 +1github.com/gardener/gardener-extension-provider-aws (Go): 1.64.0+3 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
gardenergardener-extension-provider-awsbefore 1.64.0; before 1.55.0; before 1.49.0; before 1.46.01.64.0, 1.55.0, 1.49.0, 1.46.0Patch availableCNA
—github.com/gardener/gardener-extension-provider-aws (Go)before 1.64.01.64.0Patch availableGHSA-227x-7mh8-3cf6
—github.com/gardener/gardener-extension-provider-gcp (Go)before 1.46.01.46.0Patch availableGHSA-227x-7mh8-3cf6
—github.com/gardener/gardener-extension-provider-azure (Go)before 1.55.01.55.0Patch availableGHSA-227x-7mh8-3cf6
—github.com/gardener/gardener-extension-provider-openstack (Go)before 1.49.01.49.0Patch availableGHSA-227x-7mh8-3cf6
  • gardener-extension-provider-aws Vendorgardener Affected before 1.64.0; before 1.55.0; before 1.49.0; before 1.46.0 Fixed in 1.64.0, 1.55.0, 1.49.0, 1.46.0 Patch available CNA
  • github.com/gardener/gardener-extension-provider-aws (Go) Vendor— Affected before 1.64.0 Fixed in 1.64.0 Patch available GHSA-227x-7mh8-3cf6
  • github.com/gardener/gardener-extension-provider-gcp (Go) Vendor— Affected before 1.46.0 Fixed in 1.46.0 Patch available GHSA-227x-7mh8-3cf6
  • github.com/gardener/gardener-extension-provider-azure (Go) Vendor— Affected before 1.55.0 Fixed in 1.55.0 Patch available GHSA-227x-7mh8-3cf6
  • github.com/gardener/gardener-extension-provider-openstack (Go) Vendor— Affected before 1.49.0 Fixed in 1.49.0 Patch available GHSA-227x-7mh8-3cf6

Remediation

  • Fix · CNA gardener-extension-provider-aws (gardener) Fixed in 1.64.0, 1.55.0, 1.49.0, 1.46.0
  • Fix · GHSA-227x-7mh8-3cf6 github.com/gardener/gardener-extension-provider-aws (Go) Fixed in 1.64.0 Advisory →
  • Fix · GHSA-227x-7mh8-3cf6 github.com/gardener/gardener-extension-provider-gcp (Go) Fixed in 1.46.0 Advisory →
  • Fix · GHSA-227x-7mh8-3cf6 github.com/gardener/gardener-extension-provider-azure (Go) Fixed in 1.55.0 Advisory →
  • Fix · GHSA-227x-7mh8-3cf6 github.com/gardener/gardener-extension-provider-openstack (Go) Fixed in 1.49.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-59823
  2. 2026-10-03 Alias added: GHSA-227x-7mh8-3cf6

References

  • TI-2025-29813 Bypassing project secret validation can lead to privilege escalation CVSS 3.1CRITICAL 9.9
  • TI-2025-29812 Malicious google credential in DNS secret can lead to privilege escalation CVSS 3.0CRITICAL 9.9
  • TI-2025-29814 Gardener vulnerable to metadata injection for a project secret that can lead to privilege escalation CVSS 3.1CRITICAL 9.9
  • TI-2019-09329 In Gardener before 0.20.0, incorrect access control in seed clusters allows information… CVSS 3.0HIGH 8.5
  • TI-2018-01854 Following the Gardener architecture, the Kubernetes apiserver of a Gardener managed shoot… CVSS 3.0HIGH 8.5
  • TI-2025-41264 gardenctl is vulnerable to Command Injection when used with non‑POSIX shells CVSS 3.1HIGH 8.4
See all 7 →

Sources