Moodle: course access permissions not properly checked in course_output_fragment_course_overview
Priority LOW 20CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
A flaw was found in the course overview output function where user access permissions were not fully enforced. This could allow unauthorized users to view information about courses they should not have access to, potentially exposing limited course details.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00245 15th percentileScored 2026-11-07
Fix Fixed moodle: 5.0.3moodle/moodle (Packagist): 5.0.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 5.0.0 to before 5.0.3 | 5.0.3 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 5.0.0-beta to before 5.0.3 | 5.0.3 | Patch available | GHSA-rjcm-7v2p-9265 |
- moodle Vendor— Affected 5.0.0 to before 5.0.3 Fixed in 5.0.3 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 5.0.0-beta to before 5.0.3 Fixed in 5.0.3 Patch available GHSA-rjcm-7v2p-9265
Remediation
- Fix · CNA moodle Fixed in 5.0.3
- Fix · GHSA-rjcm-7v2p-9265 moodle/moodle (Packagist) Fixed in 5.0.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62393
- 2026-10-03 Alias added: GHSA-rjcm-7v2p-9265
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-62393 · CVE Program
- CVE-2025-62393 · NVD
- FIRST EPSS
- GHSA-rjcm-7v2p-9265 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-62393 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences