Read the docs
TI-2025-38666 Aliases CVE-2025-62399GHSA-m58f-9pvv-8mp2

Moodle: password brute force risk when mobile/web services enabled

Priority LOW 39CWE-307Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-307.

Summary

Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00404 34th percentileScored 2026-11-07
Fix Fixed moodle: 5.0.3, 4.5.7, 4.4.11 +1moodle/moodle (Packagist): 5.0.3, 4.5.7, 4.4.11 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle5.0.0 to before 5.0.3; 4.5.0 to before 4.5.7; 4.4.0 to before 4.4.11; 4.1.0 to before 4.1.215.0.3, 4.5.7, 4.4.11, 4.1.21Patch availableCNA
—moodle/moodle (Packagist)5.0.0-beta to before 5.0.35.0.3Patch availableGHSA-m58f-9pvv-8mp2
—moodle/moodle (Packagist)4.5.0-beta to before 4.5.74.5.7Patch availableGHSA-m58f-9pvv-8mp2
—moodle/moodle (Packagist)4.2.0-beta to before 4.4.114.4.11Patch availableGHSA-m58f-9pvv-8mp2
—moodle/moodle (Packagist)before 4.1.214.1.21Patch availableGHSA-m58f-9pvv-8mp2
  • moodle Vendor— Affected 5.0.0 to before 5.0.3; 4.5.0 to before 4.5.7; 4.4.0 to before 4.4.11; 4.1.0 to before 4.1.21 Fixed in 5.0.3, 4.5.7, 4.4.11, 4.1.21 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected 5.0.0-beta to before 5.0.3 Fixed in 5.0.3 Patch available GHSA-m58f-9pvv-8mp2
  • moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.7 Fixed in 4.5.7 Patch available GHSA-m58f-9pvv-8mp2
  • moodle/moodle (Packagist) Vendor— Affected 4.2.0-beta to before 4.4.11 Fixed in 4.4.11 Patch available GHSA-m58f-9pvv-8mp2
  • moodle/moodle (Packagist) Vendor— Affected before 4.1.21 Fixed in 4.1.21 Patch available GHSA-m58f-9pvv-8mp2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*4.1.0 to before 4.1.21; 4.4.0 to before 4.4.11; 4.5.0 to before 4.5.7; 5.0.0 to before 5.0.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 4.1.0 to before 4.1.21; 4.4.0 to before 4.4.11; 4.5.0 to before 4.5.7; 5.0.0 to before 5.0.3 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 5.0.3, 4.5.7, 4.4.11, 4.1.21
  • Fix · GHSA-m58f-9pvv-8mp2 moodle/moodle (Packagist) Fixed in 5.0.3 Advisory →
  • Fix · GHSA-m58f-9pvv-8mp2 moodle/moodle (Packagist) Fixed in 4.5.7 Advisory →
  • Fix · GHSA-m58f-9pvv-8mp2 moodle/moodle (Packagist) Fixed in 4.4.11 Advisory →
  • Fix · GHSA-m58f-9pvv-8mp2 moodle/moodle (Packagist) Fixed in 4.1.21 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-62399
  2. 2026-10-03 Alias added: GHSA-m58f-9pvv-8mp2

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources