Moodle: hidden group names visible to event creators
Priority LOW 28CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Moodle exposed the names of hidden groups to users who had permission to create calendar events but not to view hidden groups. This could reveal private or restricted group information.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00269 19th percentileScored 2026-11-07
Fix Fixed moodle: 5.0.3, 4.5.7, 4.4.11 +1moodle/moodle (Packagist): 5.0.3, 4.5.7, 4.4.11 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 5.0.0 to before 5.0.3; 4.5.0 to before 4.5.7; 4.4.0 to before 4.4.11; 4.1.0 to before 4.1.21 | 5.0.3, 4.5.7, 4.4.11, 4.1.21 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 5.0.0-beta to before 5.0.3 | 5.0.3 | Patch available | GHSA-422v-w6c5-vq42 |
| — | moodle/moodle (Packagist) | 4.5.0-beta to before 4.5.7 | 4.5.7 | Patch available | GHSA-422v-w6c5-vq42 |
| — | moodle/moodle (Packagist) | 4.2.0-beta to before 4.4.11 | 4.4.11 | Patch available | GHSA-422v-w6c5-vq42 |
| — | moodle/moodle (Packagist) | before 4.1.21 | 4.1.21 | Patch available | GHSA-422v-w6c5-vq42 |
- moodle Vendor— Affected 5.0.0 to before 5.0.3; 4.5.0 to before 4.5.7; 4.4.0 to before 4.4.11; 4.1.0 to before 4.1.21 Fixed in 5.0.3, 4.5.7, 4.4.11, 4.1.21 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 5.0.0-beta to before 5.0.3 Fixed in 5.0.3 Patch available GHSA-422v-w6c5-vq42
- moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.7 Fixed in 4.5.7 Patch available GHSA-422v-w6c5-vq42
- moodle/moodle (Packagist) Vendor— Affected 4.2.0-beta to before 4.4.11 Fixed in 4.4.11 Patch available GHSA-422v-w6c5-vq42
- moodle/moodle (Packagist) Vendor— Affected before 4.1.21 Fixed in 4.1.21 Patch available GHSA-422v-w6c5-vq42
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 4.1.0 to before 4.1.21; 4.4.0 to before 4.4.11; 4.5.0 to before 4.5.7; 5.0.0 to before 5.0.3 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 4.1.0 to before 4.1.21; 4.4.0 to before 4.4.11; 4.5.0 to before 4.5.7; 5.0.0 to before 5.0.3 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 5.0.3, 4.5.7, 4.4.11, 4.1.21
- Fix · GHSA-422v-w6c5-vq42 moodle/moodle (Packagist) Fixed in 5.0.3 Advisory →
- Fix · GHSA-422v-w6c5-vq42 moodle/moodle (Packagist) Fixed in 4.5.7 Advisory →
- Fix · GHSA-422v-w6c5-vq42 moodle/moodle (Packagist) Fixed in 4.4.11 Advisory →
- Fix · GHSA-422v-w6c5-vq42 moodle/moodle (Packagist) Fixed in 4.1.21 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62400
- 2026-10-03 Alias added: GHSA-422v-w6c5-vq42
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-62400 · CVE Program
- CVE-2025-62400 · NVD
- FIRST EPSS
- GHSA-422v-w6c5-vq42 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-62400 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences