FastMCP vulnerable to reflected XSS in client's callback page
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0 have a reflected cross-site scripting vulnerability in the OAuth client callback page (oauth_callback.py) where unescaped user-controlled values are inserted into the generated HTML, allowing arbitrary JavaScript execution in the callback server origin. The issue is fixed in version 2.13.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jlowin | fastmcp | before 2.13.0 | 2.13.0 | Patch available | CNA |
| — | fastmcp (PyPI) | before 2.13.0 | 2.13.0 | Patch available | GHSA-mxxr-jv3v-6pgc |
- fastmcp Vendorjlowin Affected before 2.13.0 Fixed in 2.13.0 Patch available CNA
- fastmcp (PyPI) Vendor— Affected before 2.13.0 Fixed in 2.13.0 Patch available GHSA-mxxr-jv3v-6pgc
Remediation
- Fix · CNA fastmcp (jlowin) Fixed in 2.13.0
- Fix · GHSA-mxxr-jv3v-6pgc fastmcp (PyPI) Fixed in 2.13.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62800
- 2026-10-03 Alias added: GHSA-mxxr-jv3v-6pgc
References
More jlowin Fastmcp vulnerabilities
- TI-2026-25332 FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability CVSS 4.0CRITICAL 10.0
- TI-2026-21575 FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities CVSS 4.0HIGH 8.2
- TI-2025-39774 FastMCP has a Command Injection vulnerability - Gemini CLI CVSS 3.1HIGH 7.8
- TI-2025-42650 FastMCP OAuth Proxy token reuse across MCP servers CVSS 4.0HIGH 7.4
- TI-2025-38984 FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name CVSS 4.0MEDIUM 5.4
Sources
- CVE-2025-62800 · CVE Program
- CVE-2025-62800 · NVD
- FIRST EPSS
- GHSA-mxxr-jv3v-6pgc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences