FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name
Priority MEDIUM 60CWE-78Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0, a command-injection vulnerability lets any attacker who can influence the server_name field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor. This vulnerability is fixed in 2.13.0.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00227 13th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed fastmcp (jlowin): 2.13.0fastmcp (PyPI): 2.13.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jlowin | fastmcp | before 2.13.0 | 2.13.0 | Patch available | CNA |
| — | fastmcp (PyPI) | before 2.13.0 | 2.13.0 | Patch available | GHSA-rj5c-58rq-j5g5 |
- fastmcp Vendorjlowin Affected before 2.13.0 Fixed in 2.13.0 Patch available CNA
- fastmcp (PyPI) Vendor— Affected before 2.13.0 Fixed in 2.13.0 Patch available GHSA-rj5c-58rq-j5g5
Remediation
- Fix · CNA fastmcp (jlowin) Fixed in 2.13.0
- Fix · GHSA-rj5c-58rq-j5g5 fastmcp (PyPI) Fixed in 2.13.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62801
- 2026-10-03 Alias added: GHSA-rj5c-58rq-j5g5
References
More jlowin Fastmcp vulnerabilities
- TI-2026-25332 FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability CVSS 4.0CRITICAL 10.0
- TI-2026-21575 FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities CVSS 4.0HIGH 8.2
- TI-2025-39774 FastMCP has a Command Injection vulnerability - Gemini CLI CVSS 3.1HIGH 7.8
- TI-2025-42650 FastMCP OAuth Proxy token reuse across MCP servers CVSS 4.0HIGH 7.4
- TI-2025-38983 FastMCP vulnerable to reflected XSS in client's callback page CVSS 4.0MEDIUM 5.3
Sources
- CVE-2025-62801 · CVE Program
- CVE-2025-62801 · NVD
- FIRST EPSS
- GHSA-rj5c-58rq-j5g5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences