FastMCP has a Command Injection vulnerability - Gemini CLI
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, server names containing shell metacharacters (e.g., &) can cause command injection on Windows when passed to fastmcp install claude-code or fastmcp install gemini-cli. These install paths use subprocess.run() with a list argument, but on Windows the target CLIs often resolve to .cmd wrappers that are executed through cmd.exe, which interprets metacharacters in the flattened command string. This issue has been patched in version 3.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jlowin | fastmcp | before 3.2.0 | 3.2.0 | Patch available | CNA |
| — | fastmcp (PyPI) | before 3.2.0 | 3.2.0 | Patch available | GHSA-m8x7-r2rg-vh5g |
- fastmcp Vendorjlowin Affected before 3.2.0 Fixed in 3.2.0 Patch available CNA
- fastmcp (PyPI) Vendor— Affected before 3.2.0 Fixed in 3.2.0 Patch available GHSA-m8x7-r2rg-vh5g
Remediation
- Fix · CNA fastmcp (jlowin) Fixed in 3.2.0
- Fix · GHSA-m8x7-r2rg-vh5g fastmcp (PyPI) Fixed in 3.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-64340
- 2026-10-03 Alias added: GHSA-m8x7-r2rg-vh5g
References
More jlowin Fastmcp vulnerabilities
- TI-2026-25332 FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability CVSS 4.0CRITICAL 10.0
- TI-2026-21575 FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities CVSS 4.0HIGH 8.2
- TI-2025-42650 FastMCP OAuth Proxy token reuse across MCP servers CVSS 4.0HIGH 7.4
- TI-2025-38984 FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name CVSS 4.0MEDIUM 5.4
- TI-2025-38983 FastMCP vulnerable to reflected XSS in client's callback page CVSS 4.0MEDIUM 5.3
Sources
- CVE-2025-64340 · CVE Program
- CVE-2025-64340 · NVD
- FIRST EPSS
- GHSA-m8x7-r2rg-vh5g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences