Read the docs
TI-2025-40259 Aliases CVE-2025-65107

Langfuse SSO Account Takeover via CSRF or phishing attack

Priority LOW 28CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Security bypass, Tampering
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-285 and CWE-352.

Summary

Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_<PROVIDER>_CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2.95.12 and 3.131.0. A workaround for this issue involves setting AUTH_<PROVIDER>_CHECK.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00167 5th percentileScored 2026-11-07
Fix Fixed langfuse (langfuse): 2.95.12, 3.131.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
langfuselangfuse2.95.0 to before 2.95.12; 3.17.0 to before 3.131.02.95.12, 3.131.0Patch availableCNA
  • langfuse Vendorlangfuse Affected 2.95.0 to before 2.95.12; 3.17.0 to before 3.131.0 Fixed in 2.95.12, 3.131.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:langfuse:langfuse:*:*:*:*:*:*:*:*2.95.0 to before 2.95.12; 3.17.0 to before 3.131.0Vulnerablelangfuse
  • cpe:2.3:a:langfuse:langfuse:*:*:*:*:*:*:*:* Versions 2.95.0 to before 2.95.12; 3.17.0 to before 3.131.0 Vulnerable ·langfuse

Remediation

  • Fix · CNA langfuse (langfuse) Fixed in 2.95.12, 3.131.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-65107

References

  • TI-2025-36879 Improper authorization in the background migration endpoints of Langfuse 3.1 before… CVSS 3.1HIGH 7.6
  • TI-2026-19383 Langfuse Slack OAuth Installation Endpoint Lacks Authentication, Enabling Arbitrary Project Linking CVSS 4.0MEDIUM 6.3
  • TI-2025-08988 Langfuse Webhook promptRouter.ts promptChangeEventSourcing server-side request forgery CVSS 4.0LOW 2.3
  • TI-2026-30074 Improper access control in langfuse CVSS 4.0MEDIUM 5.3
  • TI-2025-39896 Langfuse vulnerable to cross‑organization enumeration of member & invitation lists via project membership APIs CVSS 3.1MEDIUM 5.0

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences