Read the docs
TI-2026-30074 Aliases CVE-2026-41487

Improper access control in langfuse

Priority LOW 29CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-284.

Summary

Langfuse is an open source large language model engineering platform. From version 3.68.0 to before version 3.167.0, there is a role-based-access control flaw in the LLM connection update flow. An authenticated, low-privileged user of role “member” in a project could request the update of an existing LLM connection to an attacker-controlled baseUrl, causing Langfuse to reuse the stored provider secret and redirect the test request to an attacker-controlled endpoint. This could expose the plaintext provider LLM API key for that connection. The attack is only possible if a user is already part of a project and has “member” scoped access. This issue has been patched in version 3.167.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00181 7th percentileScored 2026-11-07
Fix Fixed langfuse (langfuse): 3.167.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
langfuselangfuse3.68.0 to before 3.167.03.167.0Patch availableCNA
  • langfuse Vendorlangfuse Affected 3.68.0 to before 3.167.0 Fixed in 3.167.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:langfuse:langfuse:*:*:*:*:*:*:*:*3.68.0 to before 3.167.0Vulnerablelangfuse
  • cpe:2.3:a:langfuse:langfuse:*:*:*:*:*:*:*:* Versions 3.68.0 to before 3.167.0 Vulnerable ·langfuse

Remediation

  • Fix · CNA langfuse (langfuse) Fixed in 3.167.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-41487

References

  • TI-2025-36879 Improper authorization in the background migration endpoints of Langfuse 3.1 before… CVSS 3.1HIGH 7.6
  • TI-2026-19383 Langfuse Slack OAuth Installation Endpoint Lacks Authentication, Enabling Arbitrary Project Linking CVSS 4.0MEDIUM 6.3
  • TI-2025-08988 Langfuse Webhook promptRouter.ts promptChangeEventSourcing server-side request forgery CVSS 4.0LOW 2.3
  • TI-2025-40259 Langfuse SSO Account Takeover via CSRF or phishing attack CVSS 3.1MEDIUM 6.5
  • TI-2025-39896 Langfuse vulnerable to cross‑organization enumeration of member & invitation lists via project membership APIs CVSS 3.1MEDIUM 5.0

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences