Read the docs
TI-2026-19383 Aliases CVE-2026-24055

Langfuse Slack OAuth Installation Endpoint Lacks Authentication, Enabling Arbitrary Project Linking

Priority MEDIUM 61CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-284.

Summary

Langfuse is an open source large language model engineering platform. In versions 3.146.0 and below, the /api/public/slack/install endpoint initiates Slack OAuth using a projectId provided by the client without authentication or authorization. The projectId is preserved throughout the OAuth flow, and the callback stores installations based on this untrusted metadata. This allows an attacker to bind their Slack workspace to any project and potentially receive changes to prompts stored in Langfuse Prompt Management. An attacker can replace existing Prompt Slack Automation integrations or pre-register a malicious one, though the latter requires an authenticated user to unknowingly configure it despite visible workspace and channel indicators in the UI. This issue has been fixed in version 3.147.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00431 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed langfuse (langfuse): 3.147.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
langfuselangfuse3.89.0 to before 3.147.03.147.0Patch availableCNA
  • langfuse Vendorlangfuse Affected 3.89.0 to before 3.147.0 Fixed in 3.147.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:langfuse:langfuse:*:*:*:*:*:*:*:*3.89.0 to before 3.147.0Vulnerablelangfuse
  • cpe:2.3:a:langfuse:langfuse:*:*:*:*:*:*:*:* Versions 3.89.0 to before 3.147.0 Vulnerable ·langfuse

Remediation

  • Fix · CNA langfuse (langfuse) Fixed in 3.147.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-24055

References

  • TI-2025-36879 Improper authorization in the background migration endpoints of Langfuse 3.1 before… CVSS 3.1HIGH 7.6
  • TI-2025-08988 Langfuse Webhook promptRouter.ts promptChangeEventSourcing server-side request forgery CVSS 4.0LOW 2.3
  • TI-2026-30074 Improper access control in langfuse CVSS 4.0MEDIUM 5.3
  • TI-2025-40259 Langfuse SSO Account Takeover via CSRF or phishing attack CVSS 3.1MEDIUM 6.5
  • TI-2025-39896 Langfuse vulnerable to cross‑organization enumeration of member & invitation lists via project membership APIs CVSS 3.1MEDIUM 5.0

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences