Read the docs
TI-2025-41391 Aliases CVE-2025-67648GHSA-6w82-v552-wjw2

Shopware's inproper input validation can lead to Reflected XSS through Storefront Login Page

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Shopware is an open commerce platform. Versions 6.4.6.0 through 6.6.10.9 and 6.7.0.0 through 6.7.5.0 have a Reflected XSS vulnerability in AuthController.php. A request parameter from the login page URL is directly rendered within the Twig template of the Storefront login page without further processing or input validation. This allows direct code injection into the template via the URL parameter, waitTime, which lacks proper input validation. This issue is fixed in versions 6.6.10.10 and 6.7.5.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00188 8th percentileScored 2026-11-07
Fix Fixed shopware (shopware): 6.6.10.10, 6.7.5.1shopware/shopware (Packagist): 6.6.10.10, 6.7.5.1+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareshopware6.4.6.0 to before 6.6.10.10; 6.7.0.0 to before 6.7.5.16.6.10.10, 6.7.5.1Patch availableCNA
—shopware/shopware (Packagist)6.4.6.0 to before 6.6.10.106.6.10.10Patch availableGHSA-6w82-v552-wjw2
—shopware/storefront (Packagist)6.4.6.0 to before 6.6.10.106.6.10.10Patch availableGHSA-6w82-v552-wjw2
—shopware/shopware (Packagist)6.7.0.0 to before 6.7.5.16.7.5.1Patch availableGHSA-6w82-v552-wjw2
—shopware/storefront (Packagist)6.7.0.0 to before 6.7.5.16.7.5.1Patch availableGHSA-6w82-v552-wjw2
  • shopware Vendorshopware Affected 6.4.6.0 to before 6.6.10.10; 6.7.0.0 to before 6.7.5.1 Fixed in 6.6.10.10, 6.7.5.1 Patch available CNA
  • shopware/shopware (Packagist) Vendor— Affected 6.4.6.0 to before 6.6.10.10 Fixed in 6.6.10.10 Patch available GHSA-6w82-v552-wjw2
  • shopware/storefront (Packagist) Vendor— Affected 6.4.6.0 to before 6.6.10.10 Fixed in 6.6.10.10 Patch available GHSA-6w82-v552-wjw2
  • shopware/shopware (Packagist) Vendor— Affected 6.7.0.0 to before 6.7.5.1 Fixed in 6.7.5.1 Patch available GHSA-6w82-v552-wjw2
  • shopware/storefront (Packagist) Vendor— Affected 6.7.0.0 to before 6.7.5.1 Fixed in 6.7.5.1 Patch available GHSA-6w82-v552-wjw2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*6.4.6.0 to before 6.6.10.10; 6.7.0.0 to before 6.7.5.1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions 6.4.6.0 to before 6.6.10.10; 6.7.0.0 to before 6.7.5.1 Vulnerable ·shopware

Remediation

  • Fix · CNA shopware (shopware) Fixed in 6.6.10.10, 6.7.5.1
  • Fix · GHSA-6w82-v552-wjw2 shopware/shopware (Packagist) Fixed in 6.6.10.10 Advisory →
  • Fix · GHSA-6w82-v552-wjw2 shopware/storefront (Packagist) Fixed in 6.6.10.10 Advisory →
  • Fix · GHSA-6w82-v552-wjw2 shopware/shopware (Packagist) Fixed in 6.7.5.1 Advisory →
  • Fix · GHSA-6w82-v552-wjw2 shopware/storefront (Packagist) Fixed in 6.7.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-67648
  2. 2026-10-03 Alias added: GHSA-6w82-v552-wjw2

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources