Read the docs
TI-2025-41486 Aliases CVE-2025-67847GHSA-xvmh-25jw-gmmm

Moodle: moodle: remote code execution via insufficient restore input validation

Priority MEDIUM 41CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

A flaw was found in Moodle. An attacker with access to the restore interface could trigger server-side execution of arbitrary code. This is due to insufficient validation of restore input, which leads to unintended interpretation by core restore routines. Successful exploitation could result in a full compromise of the Moodle application.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00574 47th percentileScored 2026-11-07
Fix Fixed moodle: 5.1.1, 5.0.4, 4.5.8 +2moodle/moodle (Packagist): 5.1.1, 5.0.4, 4.5.8 +2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle5.1.0 to before 5.1.1; 5.0.0 to before 5.0.4; 4.5.0 to before 4.5.8; 4.4.0 to before 4.4.12; 4.1.0 to before 4.1.22; before 4.1.05.1.1, 5.0.4, 4.5.8, 4.4.12, 4.1.22Patch availableCNA
—moodle/moodle (Packagist)5.1.0-beta to before 5.1.15.1.1Patch availableGHSA-xvmh-25jw-gmmm
—moodle/moodle (Packagist)5.0.0-beta to before 5.0.45.0.4Patch availableGHSA-xvmh-25jw-gmmm
—moodle/moodle (Packagist)4.5.0-beta to before 4.5.84.5.8Patch availableGHSA-xvmh-25jw-gmmm
—moodle/moodle (Packagist)4.2.0-beta to before 4.4.124.4.12Patch availableGHSA-xvmh-25jw-gmmm
—moodle/moodle (Packagist)before 4.1.224.1.22Patch availableGHSA-xvmh-25jw-gmmm
  • moodle Vendor— Affected 5.1.0 to before 5.1.1; 5.0.0 to before 5.0.4; 4.5.0 to before 4.5.8; 4.4.0 to before 4.4.12; 4.1.0 to before 4.1.22; before 4.1.0 Fixed in 5.1.1, 5.0.4, 4.5.8, 4.4.12, 4.1.22 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected 5.1.0-beta to before 5.1.1 Fixed in 5.1.1 Patch available GHSA-xvmh-25jw-gmmm
  • moodle/moodle (Packagist) Vendor— Affected 5.0.0-beta to before 5.0.4 Fixed in 5.0.4 Patch available GHSA-xvmh-25jw-gmmm
  • moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.8 Fixed in 4.5.8 Patch available GHSA-xvmh-25jw-gmmm
  • moodle/moodle (Packagist) Vendor— Affected 4.2.0-beta to before 4.4.12 Fixed in 4.4.12 Patch available GHSA-xvmh-25jw-gmmm
  • moodle/moodle (Packagist) Vendor— Affected before 4.1.22 Fixed in 4.1.22 Patch available GHSA-xvmh-25jw-gmmm

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 4.1.22; 4.4.0 to before 4.4.12; 4.5.0 to before 4.5.8; 5.0.0 to before 5.0.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:5.1.0:-:*:*:*:*:*:*5.1.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.22; 4.4.0 to before 4.4.12; 4.5.0 to before 4.5.8; 5.0.0 to before 5.0.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:5.1.0:-:*:*:*:*:*:* Versions 5.1.0 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 5.1.1, 5.0.4, 4.5.8, 4.4.12, 4.1.22
  • Fix · GHSA-xvmh-25jw-gmmm moodle/moodle (Packagist) Fixed in 5.1.1 Advisory →
  • Fix · GHSA-xvmh-25jw-gmmm moodle/moodle (Packagist) Fixed in 5.0.4 Advisory →
  • Fix · GHSA-xvmh-25jw-gmmm moodle/moodle (Packagist) Fixed in 4.5.8 Advisory →
  • Fix · GHSA-xvmh-25jw-gmmm moodle/moodle (Packagist) Fixed in 4.4.12 Advisory →
  • Fix · GHSA-xvmh-25jw-gmmm moodle/moodle (Packagist) Fixed in 4.1.22 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-67847
  2. 2026-10-03 Alias added: GHSA-xvmh-25jw-gmmm

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources