Moodle: moodle: cross-site scripting (xss) via improper sanitization of ai prompt responses
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A flaw was found in Moodle. This cross-site scripting (XSS) vulnerability, caused by improper sanitization of AI prompt responses, allows attackers to inject malicious HTML or script into web pages. When other users view these compromised pages, their sessions could be stolen, or the user interface could be manipulated.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.5.0 to before 4.5.8; 5.0.0 to before 5.0.4; 5.1.0 to before 5.1.1 | 4.5.8, 5.0.4, 5.1.1 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 4.1.22 | 4.1.22 | Patch available | GHSA-mhf6-pp52-8wqj |
| — | moodle/moodle (Packagist) | 4.4.0-beta to before 4.4.12 | 4.4.12 | Patch available | GHSA-mhf6-pp52-8wqj |
| — | moodle/moodle (Packagist) | 4.5.0-beta to before 4.5.8 | 4.5.8 | Patch available | GHSA-mhf6-pp52-8wqj |
| — | moodle/moodle (Packagist) | 5.0.0-beta to before 5.0.4 | 5.0.4 | Patch available | GHSA-mhf6-pp52-8wqj |
| — | moodle/moodle (Packagist) | 5.1.0-beta to before 5.1.1 | 5.1.1 | Patch available | GHSA-mhf6-pp52-8wqj |
- moodle Vendor— Affected 4.5.0 to before 4.5.8; 5.0.0 to before 5.0.4; 5.1.0 to before 5.1.1 Fixed in 4.5.8, 5.0.4, 5.1.1 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.1.22 Fixed in 4.1.22 Patch available GHSA-mhf6-pp52-8wqj
- moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.12 Fixed in 4.4.12 Patch available GHSA-mhf6-pp52-8wqj
- moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.8 Fixed in 4.5.8 Patch available GHSA-mhf6-pp52-8wqj
- moodle/moodle (Packagist) Vendor— Affected 5.0.0-beta to before 5.0.4 Fixed in 5.0.4 Patch available GHSA-mhf6-pp52-8wqj
- moodle/moodle (Packagist) Vendor— Affected 5.1.0-beta to before 5.1.1 Fixed in 5.1.1 Patch available GHSA-mhf6-pp52-8wqj
Remediation
- Fix · CNA moodle Fixed in 4.5.8, 5.0.4, 5.1.1
- Fix · GHSA-mhf6-pp52-8wqj moodle/moodle (Packagist) Fixed in 4.1.22 Advisory →
- Fix · GHSA-mhf6-pp52-8wqj moodle/moodle (Packagist) Fixed in 4.4.12 Advisory →
- Fix · GHSA-mhf6-pp52-8wqj moodle/moodle (Packagist) Fixed in 4.5.8 Advisory →
- Fix · GHSA-mhf6-pp52-8wqj moodle/moodle (Packagist) Fixed in 5.0.4 Advisory →
- Fix · GHSA-mhf6-pp52-8wqj moodle/moodle (Packagist) Fixed in 5.1.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-67849
- 2026-10-03 Alias added: GHSA-mhf6-pp52-8wqj
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-67849 · CVE Program
- CVE-2025-67849 · NVD
- FIRST EPSS
- GHSA-mhf6-pp52-8wqj · GitHub Advisory Database · CC BY 4.0
- CVE-2025-67849 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences