Moodle: moodle: cross-site scripting vulnerability via inadequate input filtering in formula editor
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A flaw was found in moodle. This vulnerability, known as Cross-Site Scripting (XSS), occurs due to insufficient checks on user-provided data in the formula editor's arithmetic expression fields. A remote attacker could inject malicious code into these fields. When other users view these expressions, the malicious code would execute in their web browsers, potentially compromising their data or leading to unauthorized actions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.1.0 to before 4.1.22; 4.4.0 to before 4.4.12; 4.5.0 to before 4.5.8; 5.0.0 to before 5.0.4; 5.1.0 to before 5.1.1 | 4.1.22, 4.4.12, 4.5.8, 5.0.4, 5.1.1 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 4.1.22 | 4.1.22 | Patch available | GHSA-6mmv-f6c6-v6q8 |
| — | moodle/moodle (Packagist) | 4.4.0-beta to before 4.4.12 | 4.4.12 | Patch available | GHSA-6mmv-f6c6-v6q8 |
| — | moodle/moodle (Packagist) | 4.5.0-beta to before 4.5.8 | 4.5.8 | Patch available | GHSA-6mmv-f6c6-v6q8 |
| — | moodle/moodle (Packagist) | 5.0.0-beta to before 5.0.4 | 5.0.4 | Patch available | GHSA-6mmv-f6c6-v6q8 |
| — | moodle/moodle (Packagist) | 5.1.0-beta to before 5.1.1 | 5.1.1 | Patch available | GHSA-6mmv-f6c6-v6q8 |
- moodle Vendor— Affected 4.1.0 to before 4.1.22; 4.4.0 to before 4.4.12; 4.5.0 to before 4.5.8; 5.0.0 to before 5.0.4; 5.1.0 to before 5.1.1 Fixed in 4.1.22, 4.4.12, 4.5.8, 5.0.4, 5.1.1 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.1.22 Fixed in 4.1.22 Patch available GHSA-6mmv-f6c6-v6q8
- moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.12 Fixed in 4.4.12 Patch available GHSA-6mmv-f6c6-v6q8
- moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.8 Fixed in 4.5.8 Patch available GHSA-6mmv-f6c6-v6q8
- moodle/moodle (Packagist) Vendor— Affected 5.0.0-beta to before 5.0.4 Fixed in 5.0.4 Patch available GHSA-6mmv-f6c6-v6q8
- moodle/moodle (Packagist) Vendor— Affected 5.1.0-beta to before 5.1.1 Fixed in 5.1.1 Patch available GHSA-6mmv-f6c6-v6q8
Remediation
- Fix · CNA moodle Fixed in 4.1.22, 4.4.12, 4.5.8, 5.0.4, 5.1.1
- Fix · GHSA-6mmv-f6c6-v6q8 moodle/moodle (Packagist) Fixed in 4.1.22 Advisory →
- Fix · GHSA-6mmv-f6c6-v6q8 moodle/moodle (Packagist) Fixed in 4.4.12 Advisory →
- Fix · GHSA-6mmv-f6c6-v6q8 moodle/moodle (Packagist) Fixed in 4.5.8 Advisory →
- Fix · GHSA-6mmv-f6c6-v6q8 moodle/moodle (Packagist) Fixed in 5.0.4 Advisory →
- Fix · GHSA-6mmv-f6c6-v6q8 moodle/moodle (Packagist) Fixed in 5.1.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-67850
- 2026-10-03 Alias added: GHSA-6mmv-f6c6-v6q8
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-67850 · CVE Program
- CVE-2025-67850 · NVD
- FIRST EPSS
- GHSA-6mmv-f6c6-v6q8 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-67850 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences