Moodle: moodle: data exposure of user identifiers in urls
Priority LOW 24CWE-201Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-201.
Summary
A flaw was found in moodle. During anonymous assignment submissions, user identifiers were inadvertently exposed in URLs. This data exposure allows unauthorized viewers to see internal user IDs, compromising the intended anonymity and potentially leading to information disclosure.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00357 29th percentileScored 2026-11-07
Fix Fixed moodle: 4.1.22, 4.4.12, 4.5.8 +2moodle/moodle (Packagist): 4.1.22, 4.4.12, 4.5.8 +2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.1.0 to before 4.1.22; 4.4.0 to before 4.4.12; 4.5.0 to before 4.5.8; 5.0.0 to before 5.0.4; 5.1.0 to before 5.1.1 | 4.1.22, 4.4.12, 4.5.8, 5.0.4, 5.1.1 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 4.1.22 | 4.1.22 | Patch available | GHSA-8jrv-wx83-w3xj |
| — | moodle/moodle (Packagist) | 4.4.0-beta to before 4.4.12 | 4.4.12 | Patch available | GHSA-8jrv-wx83-w3xj |
| — | moodle/moodle (Packagist) | 4.5.0-beta to before 4.5.8 | 4.5.8 | Patch available | GHSA-8jrv-wx83-w3xj |
| — | moodle/moodle (Packagist) | 5.0.0-beta to before 5.0.4 | 5.0.4 | Patch available | GHSA-8jrv-wx83-w3xj |
| — | moodle/moodle (Packagist) | 5.1.0-beta to before 5.1.1 | 5.1.1 | Patch available | GHSA-8jrv-wx83-w3xj |
- moodle Vendor— Affected 4.1.0 to before 4.1.22; 4.4.0 to before 4.4.12; 4.5.0 to before 4.5.8; 5.0.0 to before 5.0.4; 5.1.0 to before 5.1.1 Fixed in 4.1.22, 4.4.12, 4.5.8, 5.0.4, 5.1.1 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.1.22 Fixed in 4.1.22 Patch available GHSA-8jrv-wx83-w3xj
- moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.12 Fixed in 4.4.12 Patch available GHSA-8jrv-wx83-w3xj
- moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.8 Fixed in 4.5.8 Patch available GHSA-8jrv-wx83-w3xj
- moodle/moodle (Packagist) Vendor— Affected 5.0.0-beta to before 5.0.4 Fixed in 5.0.4 Patch available GHSA-8jrv-wx83-w3xj
- moodle/moodle (Packagist) Vendor— Affected 5.1.0-beta to before 5.1.1 Fixed in 5.1.1 Patch available GHSA-8jrv-wx83-w3xj
Remediation
- Fix · CNA moodle Fixed in 4.1.22, 4.4.12, 4.5.8, 5.0.4, 5.1.1
- Fix · GHSA-8jrv-wx83-w3xj moodle/moodle (Packagist) Fixed in 4.1.22 Advisory →
- Fix · GHSA-8jrv-wx83-w3xj moodle/moodle (Packagist) Fixed in 4.4.12 Advisory →
- Fix · GHSA-8jrv-wx83-w3xj moodle/moodle (Packagist) Fixed in 4.5.8 Advisory →
- Fix · GHSA-8jrv-wx83-w3xj moodle/moodle (Packagist) Fixed in 5.0.4 Advisory →
- Fix · GHSA-8jrv-wx83-w3xj moodle/moodle (Packagist) Fixed in 5.1.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-67857
- 2026-10-03 Alias added: GHSA-8jrv-wx83-w3xj
References
Advisory 4
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-67857 · CVE Program
- CVE-2025-67857 · NVD
- FIRST EPSS
- GHSA-8jrv-wx83-w3xj · GitHub Advisory Database · CC BY 4.0
- CVE-2025-67857 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences